Z driver dead for no reason?



  • Hi folks,

    I´m using my wifi since a few month now, 1 or 2 hours per day, not much and no 24H prints. Today my Z driver stoped working. My last print yesterday was a small 45mins BLTouch attachment. I did no changes on the wifi board, just deaktivated the printer und tried to print this morning. Without success. The Z axis is complety dead. I tried to plug in the Z motor in the y axis: The motor works. The Y motor wont turn on the z axis.

    Is the board unusable or is there any workaround or warranty?

    The printer is a Delta printer with heated bed and prometheus hotend.


  • administrators

    Is there any sign of damage to the Z stepper driver chip? If no, then please eliminate other possible causes:

    • The motor current could be set to zero. Run M906 to check what current is set, and M913 to check that the current is 100%.

    • The motor or the cable could be faulty. So try plugging the X or Y motor into the Z connector instead, and see if you can move it by commanding the Z motor to move.

    If the driver has failed, ask your supplier to repair or replace the board under warranty.



  • Hi DC42,

    M906: the current is set to 1000
    M913: Says 100%

    Stepper Motor is Wantai 0.9° with 1.7 amps
    The Z motor works on Y and X axis, and the X and Y axis motors will not work on Z axis. The driver of Z Axis is hot as f…. and I burned my finger in Idle mode. The Duet wifi has been purchased directly by duet3d.com under order number 672.


  • administrators

    Hi Pascal

    Please email info@duet3d.com referencing this forum thread and we will arrange a warranty replacement.



  • @T3P3Tony:

    Hi Pascal

    Please email info@duet3d.com referencing this forum thread and we will arrange a warranty replacement.

    Done, thx 4 your support.

    Regards

    Pascal


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.