Managing Speed in Gcode for Duet



  • I'm used to working with a different flavor of gcode and I'm a little confused about controlling the speed for Duet Wifi.

    background: I am generating gcode for a custom machine using Rhino to model and Grasshopper to create code. I'm switching from a tinyg control board by synthetos to the DuetWifi. I'm used to using G1 and G0 separately with different speed assignments so that the tool will move fast when not extruding (G0 for traveling between extrusion, G1 for travel associated with extrusion). In response to the following gcode, my G0 movements are not any faster than my G1 movements. What am I missing?

    ;PRINTING_2018_SORTING_1.0.4

    ;Friday, June 5th 2020 (13:51:03)

    G90 ;ABSOLUTE DISTANCE MODE
    M82 ; EXTRUDER ABSOLUTE DISTANCE MODE
    G0 F1000 ;feedrate
    G1 F500 ;feedrate

    G92 A0 ;VERIFY AND SET A POSITION TO 0

    M567 P0 E1:0:0:0:0
    N0 G0 F1000 X89.491664 Y138.276349 Z3.000
    N1 G1 F500 X89.491664 Y138.276349 Z0
    N2 G1 F500 X94.440476 Y138.573733 Z0 E0.310
    N3 G1 F500 X99.333629 Y139.371951 Z0 E0.620
    N4 G1 F500 X104.124716 Y140.647376 Z0 E0.930
    N5 G1 F500 X108.7726 Y142.373478 Z0 E1.239
    N6 G1 F500 X113.239765 Y144.524609 Z0 E1.549
    N7 G1 F500 X117.489313 Y147.078892 Z0 E1.859



  • Hi,

    I would suspect that the firmware doesn't handle separate feed rates for G0 and G1.

    Can you simply generate each G0 or G1 command with the desired F parameter?

    Frederick



  • @fcwilt almost but not entirely true.

    In Laser and CNC mode, G0 moves are executed at the maximum feed rate available, to comply with the NIST GCode standard, This feed rate is set by the M203 command.

    But in 3d printer land, G0 and G1 are the same (more at https://duet3d.dozuki.com/Wiki/Gcode#Section_G0_G1_Move)



  • @oliof said in Managing Speed in Gcode for Duet:

    @fcwilt almost but not entirely true.

    In Laser and CNC mode, G0 moves are executed at the maximum feed rate available, to comply with the NIST GCode standard, This feed rate is set by the M203 command.

    But in 3d printer land, G0 and G1 are the same (more at https://duet3d.dozuki.com/Wiki/Gcode#Section_G0_G1_Move)

    Good to know. I will likely remember that for a week or more. 😉

    Frederick



  • @oliof and @fcwilt

    I did read that on the Duet supported Gcode page, but I should still be able to use both G1 and G0 in my gcode if for no other reason that human readability, and with the following, I would assume that I can expect the first command to travel at twice the speed of the second and third.

    N0 G0 F1000 X89.491664 Y138.276349 Z3.000
    N1 G1 F500 X89.491664 Y138.276349 Z0
    N2 G1 F500 X94.440476 Y138.573733 Z0 E0.310

    But for some reason, all travel is about the same speed...

    m203 max is defined at 6000 so I should be able to use any feedrate under that.



  • Hi,

    A couple of questions:

    What do N0, N1, etc at the start of the command do. I am not familiar with that.

    And in your M203 you have 6000 for X, Y and Z?

    Thanks.

    Frederick



  • @fcwilt

    The N0 etc is line numbers - I find it helpful for troubleshooting.

    I’ll have to report back with specifics, but - my m203 X and Y values are 6000, for Z and E they are lower.


Log in to reply