DWC connection/ SD card disconnections



  • hi,
    my printer lost connection suddenly after editing the config file and reset the board.
    first, i was not able to connect through the web.
    so i connected directly with usb and check m552 at YAT terminal, i got it to work under my requested IP.
    now i able to connect the web but every time i tried to update the config file i loose my connection and my IP (checking again with YAT)

    im not able to move axes or anything and my tool/additional axes and all my config is not applied to the board.
    the SD still show his files but almost any action cause disconnection without able to connect again.

    this was included more weird things such as:

    1. YAT working only when SD is off and only when the board power(24V) is off.- never happened to me
    2. web show printer "busy" when only connects
      and more..
      things i tried to do:
    3. update firmwares.
    4. reformatting the SD card
    5. change SD card

    all with no help i mange to connect with the web but nothing is moving and every reset i lose my connection.
    appreciate any help



  • sounds like a syntax error in you config file, which you should attach
    https://forum.duet3d.com/topic/5909/guide-for-posting-requests-for-help/1?_=1591714792429



  • @bearer said in DWC connection/ SD card disconnections:

    tax error in you config file, which you should attach

    ok tnx
    i wasn't Familiar with this guide. I'll stick to that from now on.



  • @bearer said in DWC connection/ SD card disconnections:

    nds like a syntax error in you config file, which you should attach

    still not working for me.
    I will try to refine the problem:
    the board only able to connect YAT on pc when it power is off.
    i need also to eject the SD card otherwise im getting a disconnections + wierd warnings:
    ![alt text](10b6a1b1-c006-46e7-9c6b-cad852c32575-image.png image url)

    than im able to get him work on the specific with M552.
    ![alt text](c4561231-1a2d-4137-8de7-fd7607d10592-image.png image url)

    in here im able to connect with chrome to the specific IP but i get an error that tells me SD card is not insert.
    ![alt text](e0293c0c-38a2-47c8-9deb-3ca2acccf8b0-image.png image url)
    than i insert back the SD card to is slot and send m21 command(see picture above).

    now, im able to connect and see the web interface,
    i power the Vin for the board and im still connected, see the SD files in their place and everything looks good.
    after Vin supplied i see printer "busy" on dashboard with no command sent
    ![alt text](b3bb8a0a-2666-42df-8412-12b1e90ebddc-image.png image url)
    so the printer cant get moving cause it busy.
    each time i will try to change config file save and restart the board will disappear and i back to start.
    in addition the printer will lose connection by itself and disappear as well.

    even tried to get my printer a static address still with no help.

    appreciate your advice thank you before head.

    so in advance,
    **
    im using duet 3 mainboard 6HC
    with CANBUS connection to 1 duet 3 expansion board.

    i upgraded all firmwares to the latest rrf3 version:
    in sys folder:
    Duet3_SDiap_MB6HC
    Duet3Firmware_EXP3HC
    Duet3Firmware_MB6HC
    in www folder:
    DuetWebControl-SD-3.1.1(extract files)
    **
    SEE CONFIG FILE:

    ; Configuration file for Duet 0.6 (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Tue Mar 17 2020 18:15:06 GMT+0200 (Israel Standard Time)
    
    ; General preferences
    
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin
    M568 	; tool mix ratios on
    M302 P1 S0				 ; Allow cold extrusion minimum of 0
    
    
    ; Network
    
    M552 P192.168.200.15 			; enable network and acquire dynamic address via DHCP
    ;M586 P0 S1                       ; enable HTTP
    ;M586 P1 S0                       ; disable FTP
    ;M586 P2 S0                       ; disable Telnet
    M550 P"MY PRINTER"               ; set printer name
    
    
    
    ;	Drives
    M569 P0 S1                       ; physical drive 0 goes forwards
    M569 P1 S0                       ; physical drive 1 goes forwards
    M569 P2 S1                       ; physical drive 2 goes forwards
    M569 P3 S0                       ; physical drive 3 goes forwards
    M569 P4 S0                       ; physical drive 4 goes forwards
    M569 P5 S0                       ; physical drive 5 goes forwards
    M569 P1.0 S1                     ; Drive E0  
    M569 P1.1 S1 		         ; E1 printhead  
    M569 P1.2 S1                     ; E2 printhead  
    
    
    M584 X0 U1 Y2:3 Z4:5 E1.0:1.1:1.2 									        ; Use E1 for Z axis
    M350 X16 Y16:16 Z16:16 U16 E16:16:16 I1     								        ; Configure microstepping with interpolation												;
    M92 X100 Y80.00 Z462.5 U100 E115:215:215									; set steps per mm
    M566 X500 Y500 Z60 U500 E500:800:800										; set maximum instantaneous speed changes (mm/min)
    M203 X20000 Y20000 Z2000 U20000 E10000:15000:15000								; set maximum speeds (mm/min)
    M201 X1000 Y10000 Z300 U1000 E500:1000:1000									; set accelerations (mm/s^2)
    M906 X2000 Y1800 Z2100 U2000 E2100:1700:1700 I30     								; set motor currents (mA) and motor idle factor in per cent
    M84 S0														; disable motor current reduction
    M84 S30                        											; Set idle timeout
    		
    ; Axis Limits
    M208 X0 Y0 Z0:0 U0 S1              						   ; set axis minima
    M208 X600 Y600 Z8000 U600 S0   						           ; set axis maxima
    M564 S1 H0									   ; Allow axis move without home and outside boundries
    
    
    ; Endstops
    M574 X1 P0 S1 P"ustop"   ; X min active high endstop switch
    M574 Y1 P1 S1 P"ystop"   ; Y min active high endstop switch
    M574 U1 P2 S1 P"xstop"  ; U max active high endstop switch
    
    
    
    ; Tools
    
    M563 P0 D0:1 S"TOOL 0" X3	;Define tool 0
    M563 P1 D2 S"TOOL 1" X0  	;Define tool 1
    
    M567 P0 E1.5:3 									;MIXING RATIO tool 0
    
    G10 P1 X0 Y0 									; set offset for tool 1
    G10 P0 U X45 Y-155   								; set offset for tool 0
    
    
    
    ;M308 S0 P"spi.cs0" Y"rtdmax31865" A"1 temp"		; 				
    ;M308 S1 P"spi.cs1" Y"rtdmax31865" A"2 temp"		; 				
    ;M308 S2 P"spi.cs2" Y"rtdmax31865" A"3 temp"		; 				
    
    
    ; Z-Probe
    M558 P0 H5 F120 T6000                        ; Disable Z probe but set dive height, probe speed and travel speed
    
    
    
    
    
    
    


  • a lot of white space and long lines, any errors if you run M98 config.g ?



  • @bearer said in DWC connection/ SD card disconnections:

    M98 config.g

    no errors.
    only missing p parameter (m98 pconfig.g)
    meanewhile im not sure what cause the disconnection. i downgrade the firmware version(all) again and it suddenly work well so far.
    i saw post with the same problem and same not sure solution attach here:
    https://forum.duet3d.com/topic/15714/dwc-connection-sd-card

    it maybe in house network problem but with all my action im not sure which made it work.
    thank you for advice i will improve my post techniques.
    for now i close this thread.


Log in to reply