Unexplained under extrusion issues



  • Hi all,

    I have built a voron 2.1 powered by a Duet Wifi+Duex5 running release 2.05.1. Extrusion is handled by a Mobius2 so plenty of mechanical power available there. The bed is flat (big slab of 5086 alu) with PEI and the gantry auto-levels. If I use a metal distance gauge it's well within 0.05mm accross the board so lthat seems fine.

    Extruder is calibrated to be exact, 100mm does exactly 100mm of filament (and pushes it out though the nozzle so it can handle the pressure).

    Head is an E3D v6 0.4. Sensor is a PT100 which has been tested to be accurate. Copper heating block and 40w heater at 60% duty cycle.

    Tried both Cura and SuperSlicer.

    Using ABS.

    Still I'm having issues getting a good print. Irrespective of the speed it prints. It always looks like there is massive amount of underextrusion when the head moves:

    IMG_0889.JPG

    Could this be in any way Duet's firmware? Like I'm accidentally limiting myself? Maybe I screwed up some setting that it takes not distance but volume and that's wrongly calibrated? I went over this a few times and can't seem to figure out what's going on.


  • Moderator

    Why only 60% duty cycle on the heater? Have you done a PID tuning of the hotend and bed heaters?

    As a sanity check, try using this technique for calibrating the extruder.

    https://duet3d.dozuki.com/Guide/Ender+3+Pro+and+Duet+Maestro+Guide+Part+4:+Calibration/40#s165

    Have you done a mesh bed compensation hightmap to see what the bed surface looks like? What is the z probe?



  • Hi @Phaedrux, thanks for the reply.

    The 60% stems from the PID tuning warning that the heater is too powerful. I moved the PWM back tot to the point where the warning went away. Under rapid extrusion the block does cool a few degrees, but to rule that out I'm printing a bit hotter.

    Z probe on a voron is inductive to get the gantry plane equal to the bed. This leveling is done three times every time the pinter starts and the final reported compensation by Duet is ~0.07mm . After that I switch to a mechanical pressure sensor which the nozzle taps to get the offset from the bed. Final check is by hand using a metal thickness gauge blade at a few points to see if it all went well.

    I've followed a similar guide for the extruder, under free running conditions this extrudes and retracts to the mm accurate for a 30cm move. Under load (so head attached squiting plastic) I've tried with 10cm under different feed rates which also seems to go fine.

    One thing I found in the mean time is that he extruder stepper (2A 1.8 deg unit) wasn't getting near it full power so I fixed that. Seems to have improved things a bit but it's not good yet.


  • Moderator

    There's no point in setting 60% to avoid the warning, because the warning is telling you what the full uncontrolled temp of the heater could reach. In such a failure scenario PWM is no longer being applied anyway. So might as well tune with 100% and live with the warning (and mitigate through other means of safety, like smoke alarm, have a fire extinguisher near, never leave it unattended, thermal cut outs where possible, etc.)


Log in to reply