Duet Ethernet connection issues



  • I've used this board before on a previous build and it worked fine, I am trying to rewrite the board and test the new printer but I have moved house since the board was last connected so cannot find it's IP address nor can I connect via USB for some reason, the laptop doesnt find the board (drivers are installed). I've removed the SD card and wrote it that way but still no luck connecting, any ideas?



  • I have been testing each component on the board to figure out if something is causing a fault and have found that the endstops I am using seem to cause the issue! If I remove the printer from its homed position it works fine to start up, however as soon as the printer homes itself before allowing me to begin a print it disconnects itself again, I have tried changing the endstops but it hasn't changed anything.



  • sounds as though you've wired them incorrectly.
    Please provide information about the end stops used and the way you've wired them.
    Also provide your config.g



  • This is my config.g
    config.json

    I will check over my wiring again.



  • Ok wiring fixed, I had messed up with the limit switch wiring. Next issue, the Z stopper motor, wont seem to budge, tried a different cable and motor, no luck, wiring is fine I checked this time ;D



  • Warning: motor phase A may be disconnected reported by driver(s) 1 2
    Warning: motor phase B may be disconnected reported by driver(s) 2

    This is the error I am getting while trying to get the Z motor to move to it's home position



  • Well, managed to fix that issue! I didn't have jumpers on the 2nd Z motor pins.

    Anyways! Onto the next issue! xD

    G28
    Error: G0/G1: target position not reachable from current position

    I am trying to home the printer and getting this error.

    config.json


  • Moderator

    Is this a delta printer? You may need to drop the print head down before you can move it because a tower carriage would need to move higher than it physically can to reach your commanded position.

    Please post the config.g file, not config.json.



  • config.g

    That was the issue, I moved the print head and it seems to be working alright. The next issue! The print bed and hotend show themselves to be at 2000c, I know this is the open circuit error, but can not seem to figure out what the issue is, I have changed my thermistor thinking that may be causing the issue but no luck


  • Moderator

    How do you have your heaters and thermistors connected?