Thermistor Heater n/a



  • Hi everybody, I bought an already used Duet Wifi and everything works fine except the thermistor of my hotend heater. The thermistor is only working if I upload the config.g file new. If I open the DWC after that again thermistor is showing n/a and I have to upload the config.g file again.

    Does anyone already knew this issue? Many thanks in advance for feedback.


  • Moderator

    That seems very strange. Can you please provide some more information.
    What firmware is installed? (send M115 to find out)
    What version of DWC is installed? (look in the settings tab)
    What are the heater and thermistor? where are they connected?
    Please post your config.g as well.
    If you send M98 Pconfig.g in the gcode console do you get any error messages?



  • I use Firmware version 1.21 and DWC 1.22.6.

    I use an e3d v6 with an atc semitec 104gt.

    Please find below my config.g

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.3 on Thu Jun 11 2020 22:27:38 GMT+0200 (Central European Summer Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Sparkcube Edge" ; set printer name
    M667 S1 ; select CoreXY mode

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S0 ; physical drive 0 goes backwards
    M569 P1 S0 ; physical drive 1 goes backwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z1200.00 E370.00 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X12000.00 Y12000.00 Z600.00 E3000.00 ; set maximum speeds (mm/min)
    M201 X1000.00 Y1000.00 Z100.00 E5000.00 ; set accelerations (mm/s^2)
    M906 X1300 Y1300 Z320 E1000 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X255 Y175 Z300 S0 ; set axis maxima

    ; Endstops
    M574 X2 Y1 Z2 S1 ; set active high endstops

    ; Z-Probe
    M558 P0 H5 F120 T12000 ; disable Z probe but set dive height, probe speed and travel speed
    M557 X5:250 Y5:170 S20 ; define mesh grid

    ; Thermistors
    M305 P0 T100000 B3974 R4700; Put your own H and/or L values here to set the bed thermistor ADC correction
    M305 P1 T100000 B4725 C7.060000e-8 R4700; Put your own H and/or L values here to set first nozzle thermistor ADC correction

    ; Heaters
    M307 H0 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    ;M305 P0 T10000 B3974 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    ;M305 P1 T10000 B4725 C7.060000e-8 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined


  • Moderator

    1.21 is quite ancient at this point. I think it would be a good time to try updating to 2.05.1.

    https://duet3d.dozuki.com/Wiki/Installing_and_Updating_Firmware



  • I will try it. Just to be sure, i have only to download 2.05.1 Duet2CombinedFirmware.bin with 402KB and Upload via DWC?


  • Moderator

    since you're coming from 1.21 you may need some IAP programming bin files as well, so you may want to update to 2.0 first (and include the IAP files from that release, and then 2.05.

    Once you have 2.0 installed you can upload the firmware zip file from 2.05 in its entirety and it should extract and update automatically.



  • Many thanks for the feedback. I think the update to version 2.0 worked. DWC shows now the hotend temperature.

    But now i have a new problem, the heater is off and will not heat.

    I am really sure that i have done the wiring correct.


  • Moderator

    @Phaedrux said in Thermistor Heater n/a:

    What are the heater and thermistor? where are they connected?

    If you send M98 Pconfig.g in the gcode console do you get any error messages?



  • Heater is e3dv6 and connected to E0 Heater on the board and the thermistor is an genuine atc semitec 104gt connected to E0 thermistor.

    M98 PCONFIG.G shows the following:

    HTTP is enabled on port 80
    FTP is disabled
    TELNET is disabled



  • I think its working now, i was too stupid to activate the heater 1 in the DWC 😄


  • Moderator

    Have you updated all the way to 2.05.1 yet?



  • Yes, I am Running now 2.05.1.

    But now i have a new stupid question. I can maximum choose 235 even though in the config 280 is set as maximum


Log in to reply