Fresh board, fresh upgrade. Heater issues

  • So, I have a quick (hopefully) question.

    I just replaced a thought to be bad duet board with a new one. Finally got the FW upgraded and am on 3.x.

    I moved over some of the stuff from my old config.g and the axis are working great.
    Everything is homing, times are good.

    However, when i try to heat up the bed, or the hotend, I have the bed at
    -273.1 and the heater 1 basically MIA.

    I am 99.9% sure I wired everything exactly the same as before. I am happy to provide any details to assist you in assisting me.
    thank you all...
    Here is a copy of my config.g

    thank you

  • Moderator

    @dunginhawk said in Fresh board, fresh upgrade. Heater issues:

    Finally got the FW upgraded and am on 3.x.

    Based on your config I think something is amiss. Your config is using version 2 syntax.

    Please send M115 to verify what firmware version you actually have installed. It should be 3.1.1 if you intend to be on RRF3, or 2.05.1 if you intend to stick with RRF2 for the time being.

    If you intend to be on RRF3, you may also want to create a new config using the web configurator to get the proper commands.

  • Yeah, i was afraid of that... I just have a problem knowing all the right stuff for the configurator...
    The config I have there is mostly a copy/paste (to some extent) of my version 2 config.. so yeah clearly something is amiss.

  • Ok, i went ahead and rebuilt it.
    Everything wrks except the bed heater.
    its a slow bed heater, so its throwing a fault.
    Ive tuned it, and made this change.
    Still happening though... any ideas?


  • Moderator

    Can you please share your new config.g?
    Are you saying that you've successfully tuned the bed heater and saved the results with M500 and added M501 to the end of your config.g and it's still giving you a heater fault?

  • @Phaedrux i was missing the M501 🙂 printing happily away now..
    The only outstanding issue now is the fact that my printer automatically goes up 3mm (default) before it starts printing. So its air printing.

    i can mod the Z offset in slicer settings, but id rather add it to firmware.
    Should be fairly easy, but I am not smart in these ways haha
    thanks for the 501 help

  • Moderator

    Can you copy and paste the contents of your config.g and homeall.g here? From your screen shot it looks like you are missing the offsets for your probe.

    You will need to calibrate your probe offsets and ensure your homeall is using the probe to home the Z axis.

  • 2056b27b-7bfd-4363-b866-554d38d714f7-image.png


  • I know its exactly -3 to where I need to print.
    So can i just modify that G92 Z0 to be G92 Z-3?

    thank you kindly for the help

  • Moderator

    Based on that config.g and homeall, yes, you can just change the value of the G92 Z to suit your first layer height. It's just telling the firmware how far away the nozzle is from the bed after the endstop has been triggered.

  • whats odd though is the nozzle is perfect when z is at 0. its only after the print starts does it raise up. Its like the gcode from the slicer is telling it to move up.
    But here is the first bit of gcode.

  • This post is deleted!

  • Moderator

    Looking at your config.g again I think your Z steps per mm is incorrect. This would cause the incorrect amount of movement than what's expected. You can verify this by asking it to move the Z by 10mm and measuring the resulting movement with a ruler.

    M92 Z4000 is unlikely. 400 maybe.

    You will need to know if your motor is 200 or 400 steps per rotation and the lead of your lead screws and calculate the value to be sure.

    Z_steps_per_mm = (motor_steps_per_rev * driver_microstep) / screw_lead

  • not sure how 4000 got put in there.. but that would explain why this thing when asked to move up 5mm goes up lets see about 10x that haha

  • Moderator

    The default in the config generator.

  • well, the default is turds 🙂 that seemed to have resolved it. keep u posted.

Log in to reply