Thermister issue using firmware 3.0



  • I am stetting up my delta printer on firmware 3.0 and to start used the configuration tool but for some reason i can only get my heater temperature to say n/a. What am I doing wrong, the config is below

    ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.3 on Tue Jun 23 2020 22:31:00 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Delta" ; set printer name
    M665 R104 L295.275 B104 H193.045 ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; put your endstop adjustments here, or let auto calibration find them

    ; Network
    M552 S2 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X79.00 Y79.00 Z79.00 E100.00 ; set steps per mm
    M566 X1200.00 Y1200.00 Z1200.00 E1200.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z18000.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X1000.00 Y1000.00 Z1000.00 E1000.00 ; set accelerations (mm/s^2)
    M906 X1000 Y1000 Z1000 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 Z0 S1 ; set minimum Z

    ; Endstops
    M574 X2 S1 P"!xstop" ; configure active-high endstop for high end on X via pin xstop
    M574 Y2 S1 P"!ystop" ; configure active-high endstop for high end on Y via pin ystop
    M574 Z2 S1 P"!zstop" ; configure active-high endstop for high end on Z via pin zstop

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; disable Z probe but set dive height, probe speed and travel speed
    M557 R85 S20 ; define mesh grid

    ; Heaters
    M140 H-1 ; disable heated bed (overrides default heater mapping)
    M308 S0 P"e0temp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin e0temp P"e0temp" Y"thermistor" T100000 B4138
    M950 H0 C"e0heat" T0 ; create nozzle heater output on e0heat and map it to sensor 0
    M307 H0 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H T45 ; set fan 0 value. Thermostatic control is turned on

    ; Tools
    M563 P0 S"Hotend" D0 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined

    ; Miscellaneous
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss
    T0 ; select first tool


  • Moderator

    Your heaters section doesn't look quite right.

    From the configurator just now with bsically defaults I get

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0                          ; create bed heater output on bedheat and map it to sensor 0
    M307 H0 B0 S1.00                               ; disable bang-bang mode for the bed heater and set PWM limit
    M140 H0                                        ; map heated bed to heater 0
    M143 H0 S120                                   ; set temperature limit for heater 0 to 120C
    M308 S1 P"e0temp" Y"thermistor" T100000 B4138  ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1                           ; create nozzle heater output on e0heat and map it to sensor 1
    M307 H1 B0 S1.00                               ; disable bang-bang mode for heater  and set PWM limit
    

    Do you have no bed heater?

    Also, you should update to 3.1.1



  • @Phaedrux said in Thermister issue using firmware 3.0:

    M308 S1 P"e0temp" Y"thermistor" T100000 B4138 ; configure sensor 1 as thermistor on pin e0temp M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1 M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit

    Thank you, that fixed it.



  • never mind, that seems to have fixed the thermister issue but now it is heating at a super slow, like 1 min to hit 40c.


  • Moderator

    PID Tune your heaters and save the results.

    https://duet3d.dozuki.com/Wiki/Tuning_the_heater_temperature_control



  • Perfect, it is fixed. however now when i start a print it said Error: G0/G1: target position not reachable from current position so at the end of home all i told the printer to move down 5 extra mm and that seed to fix that error. But now i am getting some awful grinding, stepper driver noise when starting a print but not when homing. however their is a slight hum noise when motors are engaged. attatched is the gcode--- 20mm_cube.gcode


  • Moderator

    @Gregory said in Thermister issue using firmware 3.0:

    But now i am getting some awful grinding, stepper driver noise when starting a print

    Where abouts is that coming from? Belts loose? Pulleys?
    Is your motor current set to 60-85% of the rated max for the motors?


  • administrators

    The first movement commands in the GCode file are these:

    G0 X21.505 Y21.505 F4800
    G0 Z0.135 F1000

    If all 3 axes home correctly, my guess is that one of the axes (probably the Z axis) can't manage the requested speed in the above commands, and you haven't set the maximum speed to a lower value in the M203 command in config.g.



  • @Phaedrux the motors are standard nema 17 motors and i am running them at 1000 and they still make a weird noise. and no the belts are tight.

    @dc42 that helped, that problem is now solved, thanks.


Log in to reply