Tool fan does not start when setting temperature



  • Hi All,

    why does

    M106 P1 C"Hotend" H1 T45 ; set fan 1 name and value. Thermostatic control is turned on
    

    start the fan when T0 reaches 45°C, but

    M106 P1 C"Hotend" H1 S0.75 T45  ; set fan 1 name and value. Thermostatic control is turned on
    

    does not start the fan?

    Already played around with the parameters, but as soon as i set the fan speed it is not spinning up.

    Thanks, Martin



  • Another thing is: when I change the fan speed in DWC both fans are changing their speed. It's not possible to change the speed for one fan but only for both although I see a slider for each.



  • @MartinNYHC said in Tool fan does not start when setting temperature:

    Another thing is: when I change the fan speed in DWC both fans are changing their speed. It's not possible to change the speed for one fan but only for both although I see a slider for each.

    Which both fans? How are they connected, how are they configured? What Duet board it is and what firmware?


  • Moderator

    @MartinNYHC said in Tool fan does not start when setting temperature:

    although I see a slider for each.

    What exactly do you see? There is a tool fan slider, which controls the fan of the currently selected tool, and there is a slider for the part cooling fan itself. In a single tool printer, they will be one and the same. The reason for having both slider makes a lot more sense on a multi tool printer. In recent versions of DWC you can hide fan sliders with the visibility button above the slider.

    M106 P1 C"Hotend" H1 S0.75 T45 ; set fan 1 name and value. Thermostatic control is turned on

    It's possible that the fan doesn't play well with PWM and is not able to spin up with the lower power. Try adding B1 parameter to give it a blip of full power for 1 second at startup.



  • I see a slider for the tool and part cooling fan:

    Screenshot 2020-06-26 at 07.23.03.png

    When moving one of them both sliders will change it's value. From my point of view it should be possible to change speed for both fans independently.

    Regarding the tool fan trigger I've added the B1 parameter:

    M950 F0 C"fan0" Q500                        	        ; create fan 0 on pin fan0 and set its frequency
    M106 P0 C"Bed" S0 H-1                   	            ; set fan 0 name and value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500                	                ; create fan 1 on pin fan1 and set its frequency
    M106 P1 C"Hotend" B1 H1 S0.75 T45	                    ; set fan 1 name and value. Thermostatic control is turned on
    

    but it is still not spinning up. It's anoriginal Slice Engineering fan for the Mosquito Hotend. I just noticed that the fan is "wobbling" a little bit but does not start rotating. As soon as I deleted the "S0.75" everything is working fine and the fan spins up at 45°C.

    Thanks, Martin


  • Moderator

    As I described, "bed" and "tool fan" are the same fan. If you had another fan called something else attached to another tool, the tool fan slider would control that fan if that tool was selected. If you don't want to see tool fan, click change visibility and hide it.

    For the fan not spinning, you can try playing with different PWM frequencies to see if the fan likes a different value. M106 F. Possible values range from 10hz to 30000hz.



  • Got it 😉

    Checked several M106 F values but nothing changed but I Just noticed that the fan will spin up for the time set with B<seconds> and then turns off again.



  • The documentation says

    RepRapFirmware 3 Notes
    
        The A, F and I parameters are no longer supported. Instead, specify the corresponding parameters in the M950 command when you create the fan.
    

    Changed it to

    M950 F1 C"fan1" Q10000 T45 T1          	                ; create fan 1 on pin fan1 and set its frequency
    M106 P1 C"Hotend" H1 S0.75				                ; set fan 1 name and value. Thermostatic control is turned on
    

    and now the fan is spinning up at 45°C 🙂


  • Moderator

    Ah yes, sorry but that. My mind is still in RRF2 mode 90% of the time.



  • No worries 🙂


Log in to reply