Connecting SSR to Duet Expansion Breakout Board



  • Hi,

    I want to connect SSR to H6 & H7 on the Duet Expansion Breakout Board.
    Can I connect the SSR+ to 5V and the SS- to H6 & H7 outputs?
    If I can't connect the SSR as I described I will be happy to know how it would be possible.

    The system I am using is:
    Controler: DUET Ethernet
    Expansions: Duet Expansion Breakout Board, 2 thermocouple daughterboard boards.
    I already have SSR connected to all heaters (bed, E0 and E1) and I need H6 & H7 also.

    I already config the controller to ready and work with the heaters using the following config:
    ; Heaters
    M305 P7 X1 T100000 B4138 S"Ph"
    M305 P0 X0 T100000 B4138 S"B"
    M305 P1 X150 T"K" S"R1"
    M305 P2 X151 T"K" S"Ht"
    M305 P6 X152 T"K" S"R2"
    M307 H0 B1 S1.00 ; enable bang-bang mode for the bed heater and set PWM limit
    M307 H1 B1 S1.00 ; enable bang-bang mode for the bed heater and set PWM limit
    M307 H2 B1 S1.00 ; enable bang-bang mode for the bed heater and set PWM limit
    M307 H6 B1 S1.00 ; enable bang-bang mode for the bed heater and set PWM limit
    M307 H7 B1 S1.00 ; enable bang-bang mode for the bed heater and set PWM limit

    I know I don't have temp. limit for my heaters, I will add them after the system will start to run.

    Thanks for the help!



  • @tal-raindel said in Connecting SSR to Duet Expansion Breakout Board:

    Can I connect the SSR+ to 5V and the SS- to H6 & H7 outputs?
    If I can't connect the SSR as I described I will be happy to know how it would be possible.

    first check how much current the SSR will draw at 3.3v, then connect H6/H7 to SSR+ and SSR- to ground if less than the respective pins can source.

    (i suppose you could move the SSR+ to 3.3v as well, but you'd have to invert the pin config, and still have to check if the pins could sink the needed current)

    missed the breakout board bit. nvm.


  • administrators

    The H6 and H7 outputs on the breakout board are active high, so i suggest you connect the SSR control input between the PWM output and Gnd of the 3-pin connector.



  • @dc42
    Thank you for the answer.

    Other problem that I have now is dead time constant, my set have high thermal mass.
    The normal tuning give error due to the system doesn't cooling fast enough.
    I used M307 to set the dead time to 60 sec but it need to be larger (around 3 min), I have a way to change the max dead time using G code or I need a new build?

    version data in the photo.

    Great thanks,
    Talversion.PNG


  • Moderator

    @tal-raindel said in Connecting SSR to Duet Expansion Breakout Board:

    I used M307 to set the dead time to 60 sec but it need to be larger (around 3 min),

    So set it to 180?



  • @Phaedrux
    You can't set it to 180 sec, there is limit in the software (I tried).


  • administrators

    Does your heater show no increase in temperature at all, 60 seconds after turning the heater on from cold?



  • @dc42
    The heater show temp increase around 60 sec after starting the heating.
    When stop heating it take around 3 min until it stop rising and start to have slow drop (All the system have thermal isolation around it).



  • I know the heater and the sensor are working from manual test I did.
    I powered up the heater manually and I have same temp. rise as i have on my standalone temp sensor i attached.
    I'm pretty sure that the problem I have is in the max dead time for the control loop. If there is some thing else worth checking I can do it.

    My system have very high thermal mass so it is normal that it will react slow to changes (rise and fall).



  • @dc42
    Hi,

    Do you have any suggestion how to over come the 60 sec limitation for the dead time?

    Great thanks for the help!


  • administrators

    @tal-raindel said in Connecting SSR to Duet Expansion Breakout Board:

    @dc42
    Hi,

    Do you have any suggestion how to over come the 60 sec limitation for the dead time?

    Great thanks for the help!

    Set a higher time constant (C parameter). The dead time can't exceed half the time constant.



  • @dc42

    Thanks, this allowing me to set the dead time manually to more then 60 sec.
    Still the auto-tune is stopping after 60 sec due "temperature is not falling", I can see change in the temperature but after 60 sec it still small fall.
    There is way to tweak this parameter also or I need to do manual calibration for each heater?
    Please correct me if i wrong in my understanding of the system but if I will set the C parameter to be very high it should be able to do the calibration?


  • administrators

    You will need to set both C and D high, with C at least 2*D.



  • I think it is solved.
    I did manual calibration for two of the heaters, I assume it will work for the other also.

    BTW, what the limits for A and C parameters?


Log in to reply