How to home all axis Ender 3



  • Hi There,

    I have now got my duet wired up. When on the web control it states the axis' arent homed and when i click home it all goes to the incorrect place.

    Can some help me understand how to get this working?

    Kind Regards





  • Here is one of my Ender 3 home all files.
    RRF2

    Now disclaimer.

    Some might not agree with this way of doing things, but this works for me.

    G91 ; Relative positioning
    G1 S2 Z5 F6000 ; Lift the Z axis relative to current position to avoid the nozzle hitting the bed
    G1 S1 X-235 F6000 ; Move quickly to X axis endstop (first pass)
    G1 X5 F6000 ; Go back a few mm
    G1 S1 X-235 F700 ; Move slowly to X axis endstop (second pass)
    G90 ; Absolute positioning
    G91 ; relative positioning
    G1 S2 Z5 F6000 ; lift Z relative to current position to avoid the nozzle hitting the bed
    G1 S1 Y-220 F6000 ; move quickly to Y axis endstop and stop there (first pass)
    G1 Y-5 F6000 ; go back a few mm
    G1 S1 Y-235 F700 ; move slowly to Y axis endstop once more (second pass)
    G1 S2 Y15 F1000 ; move the Y axis to a point where the IR probe can see the bed
    G90 ; absolute positioning
    G91 ; Relative mode
    G1 S2 Z5 F8000 ; Raise head 5mm to ensure it is above the Z probe trigger height
    G90 ; Back to absolute mode
    G1 X117 Y117 F8000 ; put head over the centre of the bed, or wherever you want to probe
    G30 ; lower head, stop when probe triggered and set Z to trigger height
    G1 S2 Z25 F8000 ; Raise the head for cleaning
    G1 X30 Y30 F8000 ; Move the head to the corner



  • Moderator

    @CaLviNx said in How to home all axis Ender 3:

    G1 S1 Y-220 F6000 ; move quickly to Y axis endstop and stop there (first pass)
    G1 Y-5 F6000 ; go back a few mm
    G1 S1 Y-235 F700 ; move slowly to Y axis endstop once more (second pass)

    surely that Y move in the middle should be positive?

    @PR1OR Here's another example from an ender 3 pro with maestro and bltouch.

    ; homeall.g
    ; called to home all axes
    ;
    ;
    M561  ; clear height map
    M400  ; wait for movement queue to empty
    M913 X45 Y45 Z45	; Reduce motor currents for homing
    M400
    G91			; relative positioning
    G1 H2 Z3 F600		; lift Z relative to current position
    G1 H1 X-250 Y-250 F4000 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 X5 Y5 F4000	; go back a few mm
    G1 H1 X-240 Y-240 F360  ; move slowly to X and Y axis endstops once more (second pass)
    G90 			; absolute
    G1 X159 Y142 F6000	; move probe to bed center
    M558 F600 A1 		; Dive fast once
    G30			; probe Z
    M558 F100 A10 		; Slow second dive with more accuracy
    G30			; probe z again
    G29 S1			; Load heightmap and enable mesh grid compensation
    G1 X10 Y10 Z10 F6000	; return head to park position
    M400
    M913 X100 Y100 Z100	; Return motor currents to normal
    M400
    


  • @Phaedrux

    I refer to my disclaimer...


    Some might not agree with this way of doing things, but this works for me.



  • Moderator

    @CaLviNx said in How to home all axis Ender 3:

    but this works for me.

    Success despite itself is still success I suppose.


Log in to reply