why does my dwc ip keep changing?



  • so i dont use my 3d printer often but every time i use it it seems like i have to connect to it with my computer and see what ip its using so i can connect to the dwc and its always different, only by 1 number but still. is there a better way to connect to it or a way to stop it from changing every time i go to use it? if i use it day after day after day it doesnt seem to do it but if i leave her sit for a few days it does. thanks for any help in advance



  • @zshoe

    What I do is assign a reservation in my DHCP server (which is often part of your router) to always assign the same IP address to a device based on the devices MAC address which is unique for every device.

    Frederick



  • It's by design of of the way IP networks operate.

    When a device boots-up, if it has been given a static IP address, it will always use that address.

    If it hasn't been given an address it will try and contact a DHCP server, which will give it an address, from a pool of address it has been configured for. Depending on your network configuration, but normally for home use, this will be the router that you use to connect to the internet, which unless you know how to make some advanced configuration changes, will be 'factory set' for the pool, to the local subnet of 253 possible hosts (computers).

    So there are 2 ways to always get the same IP address:

    1. Assign a static address in the DWC configuration, which could have knock on effects whereby the DHCP server tries to assign the same address to another device that connects to your network. this risk can be mitigated by assigning an IP address 'high-up' in the subnet range, e.g. if your IP address range is something like 192.168.1.1 through to 192.168.1.254, then assign an address in the 250's

    2. Assign reservations on the DHCP server, such that when the MAC address of your DWC device requests an IP address it is always given the same address.



  • are you not able to access the printer using its name? default to duet i think.

    try these (or replace duet with whatever you have in M550)
    http://duet.local/
    http://duet/

    as the others have alluded to you can try setting a reservation, but typically routers that do not have predictable mapping from MAC address to IP also doesn't support reservations, or local DNS - however with a bit of luck mDNS works on your computer (if its a windows machine, installing apple printer support can help make mDNS work


Log in to reply