M98 not working "macro file not found"



  • Hi,

    So I have run out of ideas, I cant get M98 to work. Macro file name is simply "test", so I thought M98 Ptest.g would work, but nope, haven't gotten it or the many variations I have tried to work, including turning off "covert all gcodes to capitals". I also tried to specify the internal SD card with P0 but that didn't work either.

    I also took out my microSD card, and reformatted it, made sure I had the correct folder structure (https://duet3d.com/wiki/SD_card_folder_structure)…. its still not working.

    Does anyone have any ideas? I had it working fine previously, so I have no idea how to fix this.

    Thanks in advance for any help!



  • Try [c]M98 P/macros/test[/c]



  • that worked! thank you so much

    do you know the reason why?



  • I haven't used M98 before
    I just looked it up the wiki
    Not sure why it worked before for you but not now
    The wiki says the default path is /sys and some firmware will look into /macros
    So probably RRF skips /macros


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.