Duet 2 Wifi - Wifi not connectin but router lists the device



  • Hello from Germany,

    I have a Vodafone Cable Router and when i setup the duet 2 wifi. The following error occurs.
    But when i login to the router i find the device as conncted device. Shown in the picture.

    Any ideas whats going on?

    680ebe2c-f79f-41a1-ad05-cc460c0212b8-grafik.png

    M587 S"19092" P"testTest91"
    ok<LF>
    m587
    Remembered networks:<LF>19092 IP=0.0.0.0 GW=0.0.0.0 NM=0.0.0.0<LF>ok<LF>
    m552
    WiFi module is idle<LF>ok<LF>
    m552 s1
    ok<LF>
    m552
    WiFi module is changing mode<LF>ok<LF>
    m540
    MAC: 24:62:ab:15:71:e1<LF>ok<LF>WiFi reported error: Timed out while trying to connect to 19092<LF>WiFi module is idle<LF>WiFi module is idle<LF>WiFi reported error: no known networks found<LF>WiFi module is idle<LF>WiFi reported error: network scan failed<LF>WiFi module is idle<LF>WiFi reported error: network scan failed<LF>WiFi module is idle<LF>WiFi reported error: network scan failed<LF>WiFi module is idle<LF>WiFi reported error: network scan failed<LF>WiFi module is idle<LF>WiFi reported error: network scan failed<LF>WiFi module is idle<LF>WiFi reported error: network scan failed<LF>WiFi module is idle<LF>WiFi reported error: network scan failed<LF>WiFi module is idle<LF>WiFi reported error: network scan failed<LF>WiFi module is idle<LF>WiFi reported error: network scan failed<LF>WiFi module is idle<LF>WiFi reported error: network scan failed<LF>WiFi module is idle<LF>WiFi reported error: network scan failed<LF>WiFi module is idle<LF>WiFi reported error: network scan failed<LF>WiFi module is idle<LF>WiFi reported error: network scan failed<LF>WiFi module is idle<LF>WiFi reported[Warning: Maximal number of bytes per line exceeded! Check the EOL (end-of-line) settings or increase the limit in the advanced terminal settings.]



  • @tifrei said in Duet 2 Wifi - Wifi not connectin but router lists the device:

    [Warning: Maximal number of bytes per line exceeded! Check the EOL (end-of-line) settings or increase the limit in the advanced terminal settings.]

    please check your terminal settings to set the line ending to LF (i believe this guide says how to do it in YAT)

    I have a Vodafone Cable Router

    Others have experienced comatability issues with Vodafone routers. After having fixed your terminal, please power up the board without the SD card and run M111 P14 S1 to enable debug for wifi, and then run M552 S1 and share the output after a while.
    (feel free to put ``` on a line over and under the text when you post it, helps with formatting)



  • Hi bearer!

    I followed your instructions!

    here is the output:

    M111 P14 S1
    Debugging enabled for modules: WiFi(14)
    Debugging disabled for modules: Platform(0) Network(1) Webserver(2) GCodes(3) Move(4) Heat(5) DDA(6) Roland(7) Scanner(8) PrintMonitor(9) Storage(10) PortControl(11) DuetExpansion(12) FilamentSensors(13) Display(15) LinuxInterface(16)
    M552 S1
    WiFi: 
    WiFi:  ets Jan  8 2013,rst cause:2, boot mode:(3,7)
    WiFi: 
    WiFi: load 0x4010f000, len 1384, room 16 
    ok
    WiFi: tail 8
    WiFi: chksum 0x2d
    WiFi: csum 0x2d
    WiFi: v3fff168c
    WiFi: ~ld
    WiFi module started
    WiFi: mode : sta(24:62:ab:15:71:e1)
    WiFi: add if0
    WiFi: wifi evt: 8
    WiFi: scandone
    WiFi: ../src/SocketServer.cpp(353): found network 19092
    WiFi: ../src/SocketServer.cpp(353): found network Verleihnix
    WiFi: ../src/SocketServer.cpp(353): found network dieter-powerline
    WiFi: ../src/SocketServer.cpp(353): found network Muckinet
    WiFi: ../src/SocketServer.cpp(353): found network Dieter Gastzugang
    WiFi: ../src/SocketServer.cpp(353): found network Vodafone Hotspot
    WiFi: sleep enable,type: 2
    WiFi: wifi evt: 2
    WiFi: scandone
    WiFi: state: 0 -> 2 (b0)
    WiFi: state: 2 -> 3 (0)
    WiFi: state: 3 -> 5 (10)
    WiFi: add 0
    WiFi: aid 1
    WiFi: cnt 
    WiFi: 
    WiFi: connected with 19092, channel 1
    WiFi: dhcp client start...
    WiFi: wifi evt: 0
    WiFi: pm open,type:2 0
    WiFi reported error: Timed out while trying to connect to 19092
    WiFi module is idle
    WiFi: state: 5 -> 0 (0)
    WiFi: rm 0
    WiFi: pm close 7
    WiFi: del if0
    WiFi: usl
    WiFi: mode : null
    WiFi: wifi evt: 1
    WiFi: STA disconnect: 8
    WiFi: wifi evt: 8
    WiFi: mode : sta(24:62:ab:15:71:e1)
    WiFi: add if0
    WiFi: wifi evt: 8
    WiFi: scandone
    WiFi: ../src/SocketServer.cpp(353): found network Verleihnix
    WiFi: ../src/SocketServer.cpp(353): found network Muckinet
    WiFi: ../src/SocketServer.cpp(353): found network 19092
    WiFi: ../src/SocketServer.cpp(353): found network Vodafone Hotspot
    WiFi: sleep enable,type: 2
    WiFi: scandone
    WiFi: state: 0 -> 2 (b0)
    WiFi: state: 2 -> 3 (0)
    WiFi: state: 3 -> 5 (10)
    WiFi: add 0
    WiFi: aid 1
    WiFi: cnt 
    WiFi: 
    WiFi: connected with 19092, channel 1
    WiFi: dhcp client start...
    WiFi: wifi evt: 0
    WiFi: pm open,type:2 0
    WiFi reported error: Timed out while trying to connect to 19092
    WiFi module is idle
    WiFi: state: 5 -> 0 (0)
    WiFi: rm 0
    WiFi: pm close 7
    WiFi: del if0
    WiFi: usl
    WiFi: mode : null
    WiFi: wifi evt: 1
    WiFi: STA disconnect: 8
    WiFi: wifi evt: 8
    WiFi: mode : sta(24:62:ab:15:71:e1)
    WiFi: add if0
    WiFi: wifi evt: 8
    WiFi: scandone
    WiFi: ../src/SocketServer.cpp(353): found network Muckinet
    WiFi: ../src/SocketServer.cpp(353): found network Verleihnix
    WiFi: ../src/SocketServer.cpp(353): found network 19092
    WiFi: ../src/SocketServer.cpp(353): found network UPC3959933
    WiFi: ../src/SocketServer.cpp(353): found network Vodafone Hotspot
    WiFi: ../src/SocketServer.cpp(353): found network UPC2746378
    WiFi: sleep enable,type: 2
    WiFi: scandone
    WiFi: state: 0 -> 2 (b0)
    WiFi: state: 2 -> 3 (0)
    WiFi: state: 3 -> 5 (10)
    WiFi: add 0
    WiFi: aid 1
    WiFi: cnt 
    WiFi: 
    WiFi: connected with 19092, channel 1
    WiFi: dhcp client start...
    WiFi: wifi evt: 0
    
    


  • Unfortunately I don't have anything else to add, but that would at least have all the information available to someone else who might help - however I suspect the issue is just the ESP8266 wifi doesn't work with the Vodaphone routers (or the other way around depending on which side isn't wifi compliant)


  • Moderator

    Given the previous reports of the vodaphone device not working I'm not sure what else to say. Please try with another router to see if the Duet wifi module is actually working, or set the duet to access point mode to see if the module is working.

    https://duet3d.dozuki.com/Wiki/Gcode#Section_M589_Configure_access_point_parameters


Log in to reply