DWC on SBC question



  • Does anyone know if I can change the behaviour of the DWC window so that it is opened in window mode like this:

    Screenshot.jpg

    I want to be able to access the desktop taskbar and display the DWC window upon boot.

    Thanks in advance.



  • Edit: tl/dr sudo sed -i 's/ --start-fullscreen/ #--start-fullscreen/' /usr/bin/launch-dwc should take care of it with a one-liner

    Thats soley handled by Rasbian; I've not tried the full desktop image but poking around DuetPI on github it may suggest you can do

    sudoedit /etc/xdg/lxsession/LXDE/autostart

    and put a # infront of launch-dwc on the last line?

    (if sudoedit doesn't want to edit the file do sudo nano /etc/.../........)



  • @bearer said in DWC on SBC question:

    Thats soley handled by Rasbian; I've not tried the full desktop image but poking around DuetPI on github it may suggest you can do
    sudoedit /etc/xdg/lxsession/LXDE/autostart
    and put a # infront of launch-dwc on the last line?
    (if sudoedit doesn't want to edit the file do sudo nano /etc/.../........)

    Yes thanks for that but the problem is the way that the window is displayed full screen on start up.

    The standard built in raspbian close,lower and minimise window icons are not available and you have to hover over the top, middle area of the screen to bring up an "X" which then allows you to lower the window. The problem I have is that on the SBC touchscreen it is very hard to get the "X" to appear so preferably I want the standard window icons available.

    What you are suggesting will just stop the window loading on start up but then after loading it manually it will still open the same way without the window icons.



  • @chas2706 if you run launch-dwc it will run the same setting, but if you launch chrome on your own it should be okay?



  • @bearer said in DWC on SBC question:

    @chas2706 if you run launch-dwc it will run the same setting, but if you launch chrome on your own it should be okay?

    I have just tried that and found out that it must be something to do with the chrome browser because it opens in exactly the same fashion, without window icons and you close it by hovering at the top and clicking on the "X" that then appears.

    Thanks for your great suggestion though.



  • thats odd; looked like its just being run in full screen mode (F11 on keyboard to toggle?) but seems odd that chrome should launch in full screen mode when not launched by the launch-dwc script that specifies --start-fullscreen

    need to set up another Pi soon I'll see if I can download the full image before then



  • @chas2706
    You can just place a short cut to the ip address and it will open in a standard window had the same issue...
    apparently changing the resolution of the screen and when asked to accept or revert selecting revert has fixed this on some installations may be worth a try but the ip link does work



  • @Carlo said in DWC on SBC question:

    @chas2706
    You can just place a short cut to the ip address and it will open in a standard window had the same issue...
    apparently changing the resolution of the screen and when asked to accept or revert selecting revert has fixed this on some installations may be worth a try but the ip link does work

    How do I create a shortcut to the ip address?



  • @chas2706
    Open chromium enter the Pi ip 192.xxx.xx.xx
    save as a favorite add to tool bar
    Also hitting F11 exits full screen mode or touch screen hold finger on screen for couple seconds and Exit full screen with appear



  • @Carlo said in DWC on SBC question:

    @chas2706
    Open chromium enter the Pi ip 192.xxx.xx.xx
    save as a favorite add to tool bar
    Also hitting F11 exits full screen mode or touch screen hold finger on screen for couple seconds and Exit full screen with appear

    Great. Thanks for that.



  • @Carlo said in DWC on SBC question:

    Open chromium enter the Pi ip 192.xxx.xx.xx

    as dwc is running on the same host using http://localhost/ would make more sense and not be dependant on user networks which may differ from 192.168/16

    if exiting full screen works then find launch-dwc and remove --start-fullscreen. if that doesn't work toggle overscan settings in raspi-config?



  • Thanks both of you.
    All sorted now.



  • would you mind sharing, others may find the thread useful later?



  • Just making you aware that when I edited autostart in /etc/xdg/lxsession and put a hash in front of @launch-dwc, when I rebooted I found that DWC still autostarted.
    In my duetpi image there is another autostart found in /home/pi/.config/lxsession/LXDE/autostart.
    It has exactly the same content as the other one in etc/xdg/lxsession but this MUST be the one the pi is looking at. Hashed out in here and DWC does not autostart.

    Also I found a quicker solution to my problem.
    In chrome I set the home page as duet3.local/ then in /home/pi/.config/lxsession/LXDE/autostart I hashed out @launch_dwc and added @chromium-browser.
    Now on startup I have chrome autostarting in windowed mode and connected to DWC.



  • Here's a copy of the new autostart file:

    @lxpanel --profile LXDE
    @pcmanfm --desktop --profile LXDE
    @xscreensaver -no-splash
    @/home/pi/./atx_on.sh
    #@launch-dwc
    @chromium-browser

    Once again, thanks everyone for your help.



  • @chas2706 said in DWC on SBC question:

    there is another autostart found in /home/pi/.config/lxsession/LXDE/autostart

    huh, interesting, and redundant. wasn't clear from the DuetPi repo, but admittedly not familiar with pi-gen at all.

    if fullscreen was the issue I'd lean towards editing launch-dwc and commenting out --start-fullscreen from there, then it works even if you add another user, change windowmanager or whatnot.

    sudo sed -i 's/ --start-fullscreen/ #--start-fullscreen/' /usr/bin/launch-dwc should take care of it with a one-liner



  • @bearer said in DWC on SBC question:

    @chas2706 said in DWC on SBC question:

    there is another autostart found in /home/pi/.config/lxsession/LXDE/autostart

    huh, interesting, and redundant. wasn't clear from the DuetPi repo, but admittedly not familiar with pi-gen at all.
    if fullscreen was the issue I'd lean towards editing launch-dwc and commenting out --start-fullscreen from there, then it works even if you add another user, change windowmanager or whatnot.
    sudo sed -i 's/ --start-fullscreen/ #--start-fullscreen/' /usr/bin/launch-dwc should take care of it with a one-liner

    Not so, because @launch-dwc does not have the extra --start-fullscreen parameters in it!





  • Sorry, I was looking in the wrong place!
    Going to try that now.



  • You are a star.

    Commenting out --start-fullscreen works and has the extra benefit of no page tabs or search bar so you basically get full screen but with the window control buttons.
    Cheers.



  • That might be the --app parameter that does that. Interesting learned something new today!

    Anyways, glad it worked out!


Log in to reply