Mesh Bed Leveling - Not setting first layer height - Start GCode ?



  • I have set up the bed leveling using your guide.

    It maps the mesh and works nicely. I do have a couple issues that I hoping you could help me out with.

    Once I have done the initial probing with G29 and get the heightmap.csv I am not quite sure what to put in the start GCode. It is not honoring the initial layer height that I set in Cura.

    1. It homes XY
    2. Moves the nozzle to the bed
    3. Never moves up to account for first layer.

    Any thoughts?

    Start GCODE
    G21 ;metric values\n
    G90 ;absolute positioning\n
    M82 ;set extruder to absolute mode\n
    M107 ;start with the fan off\n
    G28 X0 Y0 ;move X/Y to min endstops\n
    G1 X145 Y100 F3000 ;move nozzle\n
    G30 S1 ;zero\n
    G29 S1 ;load mesh\n
    G92 E0 ;zero the extruded length\n
    G1 F200 E3 ;extrude 3mm of feed stock\n
    G92 E0 ;zero the extruded length again\n
    G1 F9000"


  • administrators

    After the G30 S1 command, the head should be at the Z probe trigger height. Whether the head moves up or down when the printing starts will depend on whether your first layer height is less than or greater than the probe trigger height.



  • That's what I am thinking. I have tried another print and it is not bringing it to the desired first layer height.

    Here is the homeyz. This is with a piezo sensor. Is there anything wrong with this?

    [[language]]
    G91               	; set movement to relative mode
    G1 Z5 F200       	; move Z down 5mm
    G90               	; set movement to absolute mode
    G1 X145 Y100 F2000  	; move X and Y to probe point. ADJUST X and Y values to get Z probe over target.
    G30 S-1               	; home Z, using values from G31 in config.g
    G92 Z0			; Set Z
    G1 Z0 F200        	; move Z to Z=0
    
    

  • administrators

    The command G30 S-1 does not home Z, it probes without resetting the Z=0 height so that you can measure the trigger height. You should use G30 without the S-1 parameter in homez.g and homeall.g. You should also remove the G92 Z0 command.



  • So is G92 Z0 only when calibration when the machine starts up?



  • One last on homing. Since changing the z to the piezo sensor. The original homing doesn't work as expected anymore. It stops when either x OR y hits the endstop and does not let them both home. Any thoughts on this?

    [[language]]
    
    G91
    
    G1 Z10 F200 		; lowers bed 4mm to avoid dragging nozzle over the bed
    G1 X-340 Y240 F3000 S1  ; move up to 340/240mm in the -X (x endstop is MIN) and +Y(y endstop is MAX) directions until the homing switches are triggered
    G1 X4 Y-4 F600 		; move slowly 4mm in +X and +Y directions
    G1 X-10 Y10 S1 		; move up to 10mm in the -X and -Y directions until the homing switches are triggered
    
    G91               	; set movement to relative mode
    G1 Z5 F200       	; move Z down 5mm
    G90               	; set movement to absolute mode
    G1 X145 Y100 F2000  	; move X and Y to probe point. ADJUST X and Y values to get Z probe over target.
    G30                	; home Z, using values from G31 in config.g
    G1 Z0 F200        	; move Z to Z=0
    
    G91               	; set movement to relative mode
    G1 Z20 F200       	; move Z down 5mm
    
    

  • administrators

    Which firmware version are you using, and what sort of printer do you have? On a CoreXY printer it's normal for both axes to stop when either endstop switch is triggered, but on a Cartesian printer the second axis should keep running until its own homing switch is triggered.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.