Mesh bed compensation with no Probe Issue



  • Hi Everyone,

    I've got two issues with the manual bed probing in Mesh bed compensation (G29).
    The setup:

    • Duet 3 Mainboard 6HC + Duet 3 Expansion 3HC

    Two X steppers, one Y and two Z, all on the mainboard with their endstops. Extruders on the Expansion 3HC.

    Config is:
    ; Drives
    M569 P0.0 S1 ; physical drive 0.0 goes forwards
    M569 P0.1 S1
    M569 P0.2 S0 ; physical drive 0.2 goes forwards
    M569 P0.3 S0 ; physical drive 0.3 goes forwards
    M569 P0.4 S1
    M569 P1.0 S1 ; physical drive 1.0 goes forwards
    M569 P1.1 S1 ; physical drive 1.1 goes forwards
    M584 X0.0:0.1 Y0.2 Z0.3:0.4 E1.0:1.1 ; set drive mapping
    M350 X16 Y16 Z16 E16:16 I1 ; configure microstepping with interpolation
    M92 X128.14 Y128.14 Z1600.00 E492.45:800.00 ; set steps per mm
    M566 X1500.00 Y1500.00 Z12.00 E120.00:120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z1500.00 E1200.00:1200.00 ; set maximum speeds (mm/min)
    M201 X1000.00 Y1000.00 Z40.00 E250.00:250.00 ; set accelerations (mm/s^2)
    M906 X1200 Y1200 Z1200 E800:800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X550 Y470 Z450 S0 ; set axis maxima

    ; Endstops
    M574 X1 S1 P"!io0.in" ; configure active-high endstop for low end on X via pin io0.in
    M574 Y1 S1 P"!io1.in" ; configure active-high endstop for low end on Y via pin io1.in
    M574 Z1 S1 P"!io2.in" ; configure active-high endstop for low end on Z via pin io2.in

    ; Z-Probe
    M558 P0 H5 F120 T3000 ; disable Z probe but set dive height, probe speed and travel speed
    M557 X20:520 Y40:440 S100 ; define mesh grid

    The problems are:

    • With the dimensions of the bed I have, I want to probe only a matrix of 5x4 with a spacing of 100mm between the points. Even when resetting the board after changing the value in config.g, the machine still tries to probe way more point every 30mm (my old spacing). Are my values above the maximum spacing allowed ?

    • When performing the "manual bed probing" (I don't have a sensor due to an enclosure at 220°C), if I lower the nozzle a bit too fast or even randomly, it goes back the XYZ homing position with the probing popup still coming up but unusable. The average probing point is -7mm , maybe it is too low ?

    Thanks in advance for your answer.



  • What version of the firmware are you running?

    Use M115 to check



  • Hi,

    Instead of the S100 parameter try P5:4 which specifies a 5 x 4 grid using whatever spacing fits in the X and Y ranges you specified.

    Frederick



  • @jay_s_uk I am using the latest update