M558 probe Help with feedrate



  • I am using a precision piezo, i have it adjusted as sensitive as i can get it, it seems to need a real hard hit to trigger, i have been trying to get the feed rate a little faster, hoping a quicker tap would help, i have changed the m558 F form 300 to 1200 and i an not seeing the probing move any faster, is there any other command keeping the feed rate from changing in probing..
    I have a duet wifi, firmware 2.5, and probe set to Digital mode..

    M558 P5 I1 R0. 4 F1200 T2200

    thanks gary



  • Just a little update, when i do a G30 S-1 it probes down hits the bed but always wants to drive down past 0 to -4 or just 0ver -5.. so when the probe is triggered its not stopping, the blue led lights up with a touch and duet changes from 0 to 1000 so it looks like the probe is triggering and duet it reading it but the z doesn't stop when triggered.

    any suggestions..

    Gary


  • Moderator

    I think for the piezo you should be using P8 probe type.

    Also the probe dive speed will be limited by the M203 speed limit for the Z axis, so check that as well.



  • OK Thanks i have since changed to P8 with the same results i will check to the M203 just strange every thing seems to be triggering ok but the probe always moves around 5.0 below the Z0 and it gives me the message probe hit and the value -5 just seems like there is a long delay from when the probe is hit till duet reads it..

    Gary


  • Moderator

    Well the piezo does need a short sharp shock to trigger correctly. It will be slightly into the surface of the bed, but more like 0.5mm than 5mm. So I suspect that the z axis speed limit is keeping you from using enough speed.



  • Thanks, I was having so many problems, so i decided to bite the bullet and upgrade to ver 3.1.1 so spent most of yesterday setting up a new config.g i seem to be running ok now got homing and heaters all working haven't tried the probe yet but it show's 0 to 1000 so i know its there, as for the m203 in ver 2.5 it was set at 8000 for the x y z so i would think that would have bee high enough to get the probing seep rate up, i have it set to the same in v3.1.1 so later today i will test it out, and see how that go's..

    Only strange thing i have seen in ver3 is when homing i don't see the endstops trigger in DWC they say on NO all the time, but they do work and home ok no crashes into endstops..

    Gary


  • Moderator

    @gorf26 said in M558 probe Help with feedrate:

    Only strange thing i have seen in ver3 is when homing i don't see the endstops trigger in DWC they say on NO all the time

    Have you also updated DWC to 3.1.1?


Log in to reply