Trouble with BLTouch



  • I'm working on getting a new printer up and running. I followed the wiring / software instructions for setting up my bltouch but am unable to manually deploy or retract the probe. Occasionally on power on the probe goes into alarm mode after its self test. Wiring was done as suggested to heater 3 and z probe in. I also tried some of options on the trouble shooting page, I checked continuity for the leads connecting the probe, tried de-binding the heater pin, and changing the io address choice.

    What are the next best steps for trouble shooting?

    I have a new BLTouch and Duet Wifi version 1.02 or greater running RRF 3.1.1
    I tried to attach a zip folder of my entire config but the system said they're were invalid file types.

    retractprobe.g deployprobe.g config.g


  • Moderator

    @JPH said in Trouble with BLTouch:

    Occasionally on power on the probe goes into alarm mode after its self test.

    That part is concerning because it would indicate a problem with the probe.

    Does it always alarm on startup? Or only sometimes? Does it actually deploy and retract the pin at all?

    If you send M401 and M402 does it deploy and retract?

    If you send the command to release and reset the alarm state can you then use M401 and M402 successfully?



  • @JPH Not sure if it matters, but I have the M558 and M950 swapped in execution order:
    M558 P9 C"^zprobe.in" H5 F200 T3000 ; USE FOR BL_TOUCH! Connected to Z probe IN pin
    M950 S0 C"exp.heater3" ; USE FOR BL_TOUCH! Create servo/gpio 0 on heater 3 pin on the expansion port

    Have you checked the wiring, and for lose terminations?
    Screen Shot 2020-07-21 at 4.55.02 PM.png


  • Moderator

    @Kolbi said in Trouble with BLTouch:

    Not sure if it matters,

    It doesn't in this case. The M950 is setting up the servo control pin for the deploy and retract macro and is not directly related to the M558 pin definition which is defining the probe trigger signal pin.



  • @Phaedrux
    It only alarms out sometimes. It does do the initial deploy retract that happens at power on. It does not respond to M401 / M402 or M280 commands.

    I'll try to get it to startup and go to an alarm state and reset it.



  • @Kolbi
    The wiring matches the diagram you attached. The connectors seem to be a reasonable firm fit on the header pins. I'll remove the dupont housings and check the individual connections.



  • @Phaedrux Thanks, wasn't sure.

    @JPH Is the sensor wire run along/with stepper motor wiring? Could this be possible effects of EMI? Maybe M18 and see if the issue clears?


  • Moderator

    Mostly cause is the wiring for the servo control to the heater pin, or the probe itself. I'm leaning to the probe itself due to the error at power up.



  • @Kolbi
    At the moment nothing else is plugged in. I tried plugging everything in individually instead of in larger grouped connectors and it is working.

    I also found the issue. I accidentally grabbed a 5 pin dupont housing for initial tests instead of a 4 pin so instead of Heater3 I was connecting to E3step but the wiring still looked right to me 🙄

    Thank you both, glad nothing on the board was fried by my goof up



  • @JPH Nice! ...I've done the same thing before 😂



  • I did some more testing and also found that it will go into alarm mode if the probe is not vertical like it would be on the printer. If I hold it vertical it starts up fine. Sideways or inverted it goes straight into alarm mode.

    I don't think my other BLTouch is this picky. 🤔


  • Moderator

    @JPH said in Trouble with BLTouch:

    I don't think my other BLTouch is this picky. Smart

    FTFY




Log in to reply