M307 cannot find any heaters



  • I am trying to setup my BL touch. I currently have to connected to the heater 3 pin. I've tried issuing an M307 H3 command to get the status of heater 3 but all it returns is "Heater 3 not found". Out of curiosity I tried heaters 4-7 and they all return the same error. At the moment my BL touch is not extending when it comes to time to probe the bed.

    Can anyone suggest what might be wrong, presumably it is a config problem.


  • administrators

    My best guess is that you are running RRF 3.1.1 ands you have not configured those heater numbers. In which case, all is good.

    Please share your config.g file and your deployprobe.g and retractprobe,.g files, and tell us which firmware version you are using.



  • Well good new. I decided to totally scrap my install and I went back to the configurator. After going through the process a couple of times and tweaking the settings, by BL touch is working again.

    There is probably a good lesson to be learnt here, especially for someone just getting into reprap firmware. Don't tinker with the config any more than is absolutely necessary. It is much better to use the configurator.


Log in to reply