BL touch Working on duet2wifi but not on duex5



  • Hello.
    I am trying to use a BL touch on my 3D printer.
    First of all, I connected my BL touch to pin 31(heater 7), 5V and ground on the Duet2wifi and worked perfectly.

    Now I have connected a Duex5 expansion board and reconnected a BL touch to PWM5 on the Duex5 board.
    My RR Firmware is 2.05.
    According to use a Duex5 board, I changed the parameters in config.g, deployprobe.g and retractprobe.g files as follows.

    M307 H7->H3 A-1 C-1 D-1
    M280 P7->P3 I1->(erase) S10
    M280 P7->P3 I1->(erase) S90

    When I turned the swich on the BL touch doesn't light up.
    Are there anything else I need to modify?
    Please help me.



  • Hi,

    I believe the H7 and P7 is correct for PWM5 on the Duex5 board.

    Frederick



  • @fcwilt Thank you for your post.
    I have tried H7, P7,P7 but it didn't light up...
    This means that the PWM port is not giving any power......
    I am really confused...



  • @Hiroaki said in BL touch Working on duet2wifi but not on duex5:

    @fcwilt Thank you for your post.
    I have tried H7, P7,P7 but it didn't light up...
    This means that the PWM port is not giving any power......
    I am really confused...

    I checked my setup and this is what I have:

    M307 H7 A-1 C-1 D-1			; step 1 - disable E6 heater to enable PWM5 - PWM signal still appears on E6 connector
    M558 P9 H2 F600 T12000 A5 S0.01 R0.2	; step 2 - set probe configuration - part 1
    G31 X0 Y24.5 Z1.475 P25			; step 3 - set probe configuration - part 2
    M280 P7 S160				; clear BLTouch alarm (if any)
    

    Frederick



  • This post is deleted!


  • @fcwilt

    Good morning.
    Thank you so much.
    I have found that there was no jumper on the duex5 board which is to set 5V aux select.
    No other jumper is on the Duex5 board now.
    I hope it's ok...


Log in to reply