Baby Stepping Not Effective? Z Probe offset does nothing?



  • Example situation:

    Starting a print at .2mm layer height with first layer at .15mm. The printer begins its routine and when it starts to print, its significantly too high above the bed… so, you use the baby stepping implemented in 1.18.1 firmware/1.15a web interface... and nothing happens. It'll go up, but once you hit 0 it no longer goes down. Kind of defeats the purpose in my opinion. if for whatever reason the sensor probing causes your nozzle to be significantly too high, then you can't adjust it back down!

    As a side note with this, the z offset doesn't appear to do anything at all.... i've put it as high as 10mm and it still stays exactly the same. dunno why. This printer was working perfectly fine until a part on the x gantry broke (its a home made prusa i3 style printer). i didn't realize it had broken and though somehow the z probe was just messed up, so i moved it down to better compensate. Now that i fixed the broken part, i need to redo my calibration for the z probe offset... but it doesn't do anything. makes me wonder if it had never done anything prior to the breaking, and i was just magically perfectly correct with my physical adjustment of the z probe...



  • Well I wouldn't expect baby stepping to move the head below Z=0 because if the machine is otherwise set up correctly, then the print head would start machining grooves in the build plate. I'm happy to see that baby stepping has that safety feature built in. It is designed to make tiny adjustments to the first layer height - not to do crazy big adjustments because the machine has fundamental faults.

    When defined and set correctly the Z offset works perfectly. If it didn't, this forum would be full of posts saying otherwise. Suggest you post your config.g and homing files and maybe re-phrase the issues you are having in order to elicit some constructive help and advice.



  • Is your IR sensor functioning properly? You can test it with a piece of paper or something to make sure it is still triggering.

    If in the x-gantry damage the IR probe was damaged, it will no longer work and can result in trouble like you observe.



  • If you want to go below z=0 then set your z axis minimum to -2, but watch out for head crashes.



  • The entire reason for a baby stepping function, is to adjust the z height yes, which INCLUDES GOING DOWN. If my nozzle is sitting 3mm above the bed for some weird reason, then instead of having to cancel the print, moving it down should be an option. baby stepping is meant to adjust, not to hinder. So if it doesn't go down, then its useless.

    i'm using an inductive sensor, not IR. I want to try the IR but just haven't gotten around to buying one. The X Gantry was damaged because for whatever reason, the layers split apart. it wasn't cracked or any visible damage to it until suddenly there was a 'crack' while it was moving upwards, and it separated from the brass nut and linear bearings. I managed to fix it by gluing it back together, but am desperately trying to get the z height offset fixed so i can print viable replacements. I had some previously, but turns out the GF thought they were 'useless bits of plastic' and threw them away…. so annoyed at that... but anywho!

    Homeall.g -> https://pastebin.com/BNi2T1dW
    Homez.g -> https://pastebin.com/Fb8MyXFU
    Config.g -> https://pastebin.com/S0EmaJWK

    the Z3 in the 'tell it where we're at' section was my most recent attempt at an extreme change to see if it was actually being affected… which, it isn't. No matter what I set it to, it still sits about 1-2mm above the bed. baby stepping does nothing, setting the Z offset in the tool head section does nothing, changing the value of the 'where are we at' in either homez or homeall does nothing. it remains in the exact, same, spot.

    Quick Edit:
    (Also yes, I am turning the machine off to reset after changes just in case it needs it, and home everything, and run a bed compensation with 81 points... still doesn't do anything. which is another super sore point for me... I hate power cycling the duet... because you have to do it 20-30 times before it'll start the webserver.... )



  • It sounds like you're having a hard time with it and we've all been there.

    What do you need printed? I'll make you some parts and send them to you. You can return the favour sometime.

    It won't go below z=0 to help to prevent head crashes. Just physically raise your inductive sensor 3mm and home. And set your z axis minimum to -2mm to give you a bit of leeway to adjust using babystepping. Be aware it takes a move or two to kick in, so try printing something with lots of small turns. Once you've got the first layer you want add or subtract the z difference you babystepping to the probe z offset G31 in config.g.

    If your webserver take 20 goes to start maybe it's an issue with poor wifi signal, I put a router 4 feet from the machine and its solid.


  • administrators

    If you need to move your print head to below where the printer thinks Z=0 is, then you must have a large height error after homing or Z probing, which you need to sort out. However, you can tell the firmware to allow movement below Z=0 if you wish, the minimum height allowed after homing is the Z parameter in the M208 S1 command in config,.g.

    You don't need to reset the printer after making changes, you can just send the changed commands manually, or send M98 Pconfig.g. Bear in mind that certain settings are saved in config-override.g when you run M500, and if your config.g file invokes config-override.g at the end (either directly or by executing M501) then instead of editing config.g you should send the new command and then send M500. The commands that M500 saves to config-override.g are:

    G31 (Z probe trigger height, offsets and threshold)
    M307 (heater models)
    M301 (if you have defined your own PID parameters instead of letting the firmware generate them from the heater model)
    M665 and M666 (delta printer calibration parameters)



  • THANK YOU dc42 AND DjDemonD! That must be what i'm doing wrong! I had forgotten COMPLETELY about the G31 command in the config.g! I was oddly thinking that the offset was done via the homing files! I'll get right to changing that and seeing if that fixes everything. The Z Probe is drastically lower than it was previously (still not further down than the nozzle though) because at the time, the nozzle was crashing into the bed before the sensor ever triggered. That's when I found out that the 'crack' I had heard earlier in the day was the gantry breaking. I'll fiddle with the G31 and get back to ya guys!

    Also I need to apologize as well. I know my comments and such probably came off as snapping and rude, but it wasn't ever my intention… trying to get a printer to 'work' for 3-4 days in a row with zero success, specially when the printer was running near perfect prior, really eats away at a person's mind T-T



  • Hate to say it, but still nothing. The height above the bed still doesn't change what so ever… If I home and then stick a piece of paper under the nozzle and tell it to go to zero, it will go to just the right height. But once you tell it to print, it stays leagues away from the bed... and the print file is at a .25 layer height for the first layer, but its several mm away from the bed as usual. IDK what's happened or why it is being so fickle when the first time I had 'calibrated' it, it was a breeze and only took two tries... but now its like nothing I change takes effect, and there isn't anything in the config-override.g except for the thermistor table.

    I'm plum out of ideas at this point after spending 3-4 days trying to get a stupid z probe to work... absolutely nothing I change has ANY effect once the print starts. It all works when just moving the head around in the web interface, but once it takes off and starts to print, its like nothing was ever changed. I've even went into slic3r and changed settings around to see if i could get it to work that way but still nothing.... its stuck 2-3mm above the bed and baby stepping still does nothing. even with it set to go -2 as the minimum, hitting the button to change the baby stepping yields nothing. I even let it print the entire first layer to see if somewhere along the lines it would change, and the nozzle never lowers. Can watch the 'current z position' in the interface and it just stays there at .25 the entire time, never budges...

    EDIT:
    Can def confirm with this... I can do a Home Z and it'll go to the right height, I can use Home All and it'll go to the right height. But if I run "Auto Bed Compensation" then at the end it adds 2.51mm ontop of everything for no apparent reason.



  • you should probably post your config, also what is your Z offset set to?

    edit: missed the config link, let me look

    have you tried homing X and Y only, and then moving the probe to the center of the bed then using G30 to home with the probe, I dont see G30 used in your homing files, this tells the firmware to home l;istening for the probe to trigger, and then measuring the distance from the nozzle to the bed. If you still are still you a Z endstop as well as a Z-probe, you wont be able to use compensation or probe homing as it conflicts with the use of those features.



  • Something is amiss this all suggests there is some setting not right. Post a config.g and your home files plus a gcode file of something small like a 20x20x10 cube.



  • Config was already posted. is the last paste bin above. and as of right now, my G31 'offset' is Z0.3. My "Where are we at" 'offset' in the homeall.g and homez.g are both Z0.9.

    This gives me the proper clearance on the nozzle when I tell the printer to go to Z0. After a 'bed compensation' it moves everything up by 2.51mm. I looked at the bed.g file and found something interesting but I'm not sure if it really matters. when I look at the variables that can be given to G31 and G30, the last line in my bed.g looks odd. It is G30 P4 X100 Y100 H0 Z-99999 S (supposed to make it probe the center of the bed since it is slightly deformed thanks to the nozzle having crashed into the bed previously with a RAMPS set up). But, according to the list of parameters that can be passed to G30, that S should have a value after it, and shouldn't just be left alone. I initially looked at the parameters that can be passed to it because I wondered what H0 was for, which apparently is a height correction. I thought maybe this would be something that I might have to change to match my offset or something, but that's when I noticed its examples for the S, and that mine had nothing listed after it… Is this an issue?

    Also while looking at the examples, it gave me an idea. So someone let me know if my flow of logic/thinking is correct or wrong with this.

    To get as close to an accurate calibration of the Z probe as possible, could I just:

    Set my homez/homeall files to report 0.
    Set my G31 Z offset to 0.
    Tell my printer to home all and wait till it finishes.
    Tell the printer to move the nozzle to the probed location and go to Zero, then decrease by 0.1 until the paper is slightly caught.
    Write down the value it then states.
    THEN send it G92 Z0 (This should tell the printer that we are now at Zero like it is supposed to be).
    Tell the printer to move back to the previous XY so that it is back to the position it needs to be in to reprobe the exact same spot.
    NOW I send G30 S-1. (This should tell it to lower until the sensor is triggered, and remain there without changing anything)
    So now I write down the 'current z value'. (This should give me my Z offset for G31 if I am correct)

    With all that, I should be done? It 'should' be completely fine at that point? I'm not 100% sure if the first value I write down after doing the initial homing should be inserted into the homeall.g/homez.g files as the G92, or if it isn't needed at all... Someone let me know if this thought process is correct?



  • @Sniffle:

    you should probably post your config, also what is your Z offset set to?

    edit: missed the config link, let me look

    have you tried homing X and Y only, and then moving the probe to the center of the bed then using G30 to home with the probe, I dont see G30 used in your homing files, this tells the firmware to home l;istening for the probe to trigger, and then measuring the distance from the nozzle to the bed. If you still are still you a Z endstop as well as a Z-probe, you wont be able to use compensation or probe homing as it conflicts with the use of those features.

    The homing files are the same as when I got the firmware and all that set up from the get go. As in, I loaded up the firmware, and all I ever did was change the G92 to the value I had thought was needed. And then added a G1 move so that the nozzle would go to the probed location once the homing was done. I'm just now finding out that there is a G30 that needs to be used for such things as well. Its all located inside the bed.g file apparently, and that's where things seem to be screwing up if I'm looking at everything right.

    I genuinely do not know how my printer was ever working so amazingly well the first time if all the values I had entered literally had done nothing lol. Must have been insanely lucky and just had the probe at the exact height needed.



  • Ok following the thing I wrote above, I had to lower the nozzle to -.70 to get the paper to just barely catch.

    I then moved the probe back to where it needs to be to reprobe, told it to move up 10mm so that G30 S-1 could work, and when it ran, Z was at .66mm. So with those numbers, I am assuming the .66 needs to go in the G31 command in the Config.g? Wait… no... that wouldn't make as much sense... it would need to add the difference between the .66 and the -.70 so that it would actually lower itself enough, correct?

    EDIT:
    Nah disregard the last thingy there. If I send G92 Z0 to clear it out, and then tell it to lower by .66 then it fits perfectly still. So I didn't need to add anything onto that.

    EDIT2:
    I think I see what Sniffles means. It appears that the homing files are just set to detect an endstop, and not to be used with a probe. So instead of it being Z-9999 S1 it should just be G30, Correct?



  • correct, and if you have a Z-min endstop that is in use on the printer, and the height that the nozzle needs to reach is below that Z-min endstop, you will crash into and possibly dmamage the Z-min endstop. it is better to not use one when using a probe to home and probe the bed. you are better off to use the probe to home and physically remove the Z-min endstop as it is being physically replaced and functionally replaced by the Z-probe.

    It wasnt stated if you use a Z-min endstop, I am just stating the reason why you don't need one, just in case you do.



  • @Sniffle:

    correct, and if you have a Z-min endstop that is in use on the printer, and the height that the nozzle needs to reach is below that Z-min endstop, you will crash into and possibly dmamage the Z-min endstop. it is better to not use one when using a probe to home and probe the bed. you are better off to use the probe to home and physically remove the Z-min endstop as it is being physically replaced and functionally replaced by the Z-probe.

    It wasnt stated if you use a Z-min endstop, I am just stating the reason why you don't need one, just in case you do.

    Nope I don't have a Z end stop, just the inductive sensor. I didn't know that the homing files were automatically set up for end stop usage. As previously stated, the files were set up just as they are when the duet is initially started up with the exception of a movement command and changing the reported value.

    Also, after some trial and error with the G30 inserted in the homing files instead of the G1 Z-9999 S1 commands, it has successfully homed and returned to the proper location for Z0!

    NOW I just need to hope and pray it STAYS THAT WAY after it does the quick 5 point 'bed compensation' if it does that, then hopefully everything should be set!



  • ALRIGHT! I'm closer finally! After a bed compensation, THINGS HAVE CHANGED… Except, now its too low (by .60) instead of being several mm higher. Least now I've gotten somewhere and not feeling like I'm demonstrating the definition of insanity!



  • SUCCESS! I changed the G31 value in the 0.94 and it appears to be as perfect as can be after a bed compensation! .66 was too low apparently, and so I added the difference it was missing and then it became too high, and slowly took away .10 from it until after a bed compensation it fit the paper just right!

    Starting a quick print to see if it actually remains working. And if it does, THANK YOU ALL SO MUCH for putting up with an idiot such as myself lol. I wouldn't have ever known that G30 was needed in the homing files if it wasn't for all of you!



  • No worries. Enjoy, don't let it annoy you more than absolutely necessary.



  • FINALLY! Print started and its actually sticking!

    Thanks again so much guys. Never would have figured it out or gotten it to work at all on my own. Power of the internet for ya!

    Also, sorry for the large picture if it shows up that way. I did the preview thingy but I couldn't figure out how to make the image smaller…


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.