Mesh Bed Compensation with only one Z-Axis



  • Hi,

    i know there are may discussions about "Mesh Bed Compensation" in this forum. But i couldn't find a answer why Mesh Bed compensation is only possible with two or more Z-Axis. As far as i understand it is, that the independend Z-Axis are only there to level the bed. And not to compensate any hills in the heatbed am i right?

    Let's say i use a Heated bed, which mostly everybody uses, i get more or less warping effect of the printbed due to different heatbed temperatures.
    What i really want is that my Z-axis is moving up or down at the "Hills of the Heatbed" so that i get a consistant layerheight of the first layer.

    So why doesn't work it with only one Z-Axis either or does it and i did got this wrong?



  • Hi,

    "Mesh bed compensation" is not the same as "auto bed leveling using multiple Z steppers".

    For mesh bed compensation all you need, to keep it simple and convenient, is a Z probe. It matters not how the bed is moved up and down, be it via one stepper motor or several.

    On my FT-5 there is one stepper motor driving two Z axis lead screws via a belt. The leveling of the bed is done manually. Initially by adjusting the pulley on one of the lead screws to get the bed frame level. Then the bed itself is leveled via four "thumb screws". Once level it stays that way for a long time.

    For the Z probe I use BLTouch v3 devices but there are several other devices that folks use with success.

    Here is something you can read:

    https://duet3d.dozuki.com/Wiki/Using_mesh_bed_compensation

    Frederick



  • @fcwilt thank you for clarifying the difference.

    I recently tried Mesh Bed Compensation at my own printer. I used G29 and Probed the Bed with my BL-Touch, i got also a heighmap.csv file... and enebled the Mesh Bed Compensation but it didn't worked (Z-Axis was not correcting the heigh or low spots). Is there maximum error needed that the compensation works? Because i also created an error of over 1 mm to see if the Z-Axis is moving.

    I try it again and see if it works.



  • @Philipp-R said in Mesh Bed Compensation with only one Z-Axis:

    y tried Mesh Bed Compensation at my own printer. I used G29 and Probed the Bed with my BL-Touch, i got also a heighmap.csv file... and enebled the Mesh Bed Compensation but it didn't worked (Z-Axis was not correcting the heigh or low spots). Is there maximum error ne

    did you reload the grid at the start of the print.



  • @Philipp-R

    Did you include the step of setting the Z=0 Datum using G30 before creating the height map and before loading the height map when printing?

    Frederick



  • @davidvh86 no i did not included the loading sequence at the beginning of the print but i'll try it 🙂



  • @fcwilt Yes i did a G30 command but i think i didn't reload the heighmap



  • i think its a g30 to get your zero then G29 S1 to load the grid. I wasnt sure if it loaded automatically so i included it in my start code. I set the coordinates for the center of my bed in relation to my probe, run a g30 then follow it with a g29 s1 to load the gridmap. Again it might load automatically but i played it safe and put it in my code. make sure you run the g30 before you run the initial bed leveling sequence.


  • Moderator

    Yes at some point the heightmap must be loaded with G29 S1 (or created fresh with just G29). Usually this would be added to the slicer start gcode AFTER the z axis has been homed with the probe.


Log in to reply