Duet wifi connection issues



  • Hi Guys hoping you can help.
    I have been using the duet wifi for some time with no issues but recently I have been unable to get it connected to the wifi.
    The chip used to flash blue when connecting this no longer happens. I have tried updating to the latest firmware still no luck.
    When I sue M552 S0 followed by an M552 I get a message informing me that "Network is disabled, configured IP address: 0.0.0.0, actual IP address: 0.0.0.0" this is the same as M552 s1 but instead of network disabled it reads network enabled.
    I have tried yo clear the saved network information using M588 s"*" but that responds with the message "Error: M588: No WiFi interface available". something I have been able to find in any other threads.
    Any help would be appreciated I have provided a copy of M122 Diagnostics below.
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 3.1.1 running on Duet Ethernet 1.02 or later
    Board ID: 08DJM-9178L-L2MSD-6JKD2-3S86Q-K9DYN
    Used output buffers: 1 of 24 (1 max)
    === RTOS ===
    Static ram: 27980
    Dynamic ram: 91884 of which 20 recycled
    Exception stack ram used: 256
    Never used ram: 10932
    Tasks: NETWORK(ready,1980) HEAT(blocked,1456) MAIN(running,2300) IDLE(ready,80)
    Owned mutexes:
    === Platform ===
    Last reset 00:10:16 ago, cause: software
    Last software reset at 2020-07-31 16:35, reason: User, spinning module GCodes, available RAM 8496 bytes (slot 3)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0441f000 BFAR 0xe000ed38 SP 0xffffffff Task MAIN
    Error status: 0
    MCU temperature: min 24.3, current 24.6, max 25.2
    Supply voltage: min 1.7, current 1.7, max 1.7, under voltage events: 0, over voltage events: 0, power good: no
    Driver 0: ok, SG min/max not available
    Driver 1: ok, SG min/max not available
    Driver 2: ok, SG min/max not available
    Driver 3: ok, SG min/max not available
    Driver 4: ok, SG min/max not available
    Date/time: 1970-01-01 00:00:00
    Cache data hit count 1162930394
    Slowest loop: 59.49ms; fastest: 0.08ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0, resets 0
    === Storage ===
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest read time 1.4ms, write time 0.0ms, max retries 0
    === Move ===
    Hiccups: 0(0), FreeDm: 169, MinFreeDm: 169, MaxWait: 0ms
    Bed compensation in use: none, comp offset 0.000
    === MainDDARing ===
    Scheduled moves: 0, completed moves: 0, StepErrors: 0, LaErrors: 0, Underruns: 0, 0 CDDA state: -1
    === AuxDDARing ===
    Scheduled moves: 0, completed moves: 0, StepErrors: 0, LaErrors: 0, Underruns: 0, 0 CDDA state: -1
    === Heat ===
    Bed heaters = -1 -1 -1 -1, chamberHeaters = -1 -1 -1 -1
    === GCodes ===
    Segments left: 0
    Movement lock held by null
    HTTP is idle in state(s) 0
    Telnet is idle in state(s) 0
    File is idle in state(s) 0
    USB is ready with "M122 " in state(s) 0
    Aux is idle in state(s) 0
    Trigger is idle in state(s) 0
    Queue is idle in state(s) 0
    Daemon is idle in state(s) 0
    Autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 1.02ms; fastest: 0.00ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0), 0 sessions
    HTTP sessions: 0 of 8
    Interface state establishingLink, link down



  • Is that the whole M122? Seems to be missing a part of the Wifi?

    I.e. something like:

    ...
    === Network ===
    Slowest loop: 203.13ms; fastest: 0.08ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 1 of 8
    - WiFi -
    Network state is running
    WiFi module is connected to access point 
    Failed messages: pending 0, notready 0, noresp 2
    WiFi firmware version 1.23
    WiFi MAC address ac:3a:bc:5e:35:8a
    WiFi Vcc 3.37, reset reason Turned on by main processor
    WiFi flash size 4194304, free heap 25784
    WiFi IP address 10.10.0.196
    WiFi signal strength -59dBm, reconnections 1, sleep mode modem
    Socket states: 0 0 0 0 0 0 0 0
    


  • That is the whole 112 that is returned


  • Moderator

    Weird. It's like it doesn't see the wifi module at all anymore.

    Can you try flashing the wifi module?

    Download this file: https://github.com/Duet3D/RepRapFirmware/releases/download/2.05.1/DuetWiFiServer-1.23.bin

    Rename it to be just DuetWiFiServer.bin and place it on the SD card. Boot it up over USB and send M997 S1 to try and flash the wifi module.



  • I have tried flashing already but will try again tomorrow morning, also a bit of added behaviour that I forgot to mention, every now and again after turning on and off the WiFi will work without any issue, probably one in 20 times (on/off).
    Again will try to flash tomorrow morning and see if it makes any difference.



  • if you can get a close up of the wifi module solder joints that might be interesting to see. (best approach might be one picture from either side, good ambient lighting and in focus)



  • @Phaedrux
    So I have re flashed the wifi module again this morning and it worked! I tried this several times yesterday with no success but this time every thing worked as expected and I'm once again connected to wifi. I guess this will be one of those times where I will never truly know what went wrong. Thanks for the help.


Log in to reply