Heater config struggles



  • I have a pellet extruder with 3 heaters. Each heater and thermistor is rated up to 500C.

    The sensors are not stable at room temperature, so I have been running the heater tuning by starting at a higher temperature (75-100C). I have been able to complete tuning up to 250 (M303 h2 S250) but any higher and the tuning will time out before completing.
    I cannot set an active temperature for any of these heaters without a half hour of heating fault->reset fault->set heater active cycles.
    The tuning parameters are not right, because I get overshoots when trying to go from 240-250, for example.

    We no longer have a simple command to tell RRF that the max temp for this sensor/heater is 480C (M143).
    Can anyone suggest some configuration or tuning tricks to get these heaters tuned properly?

    Running a Duet 2 ethernet board, RRF 3.1.1.
    Thanks in advance.


  • Moderator

    @Billwhit said in Heater config struggles:

    We no longer have a simple command to tell RRF that the max temp for this sensor/heater is 480C (M143).

    You still have M143. What do you have it set to?

    What are the thermistors? Do you have known values for them?

    What are the heaters? What wattage? What voltage are you running?

    What happens when you start tuning from room temp?

    Share your config.g.



  • Thank you for the information!
    My M143 is back in.
    Here is my config.g
    The heaters and thermistors are custom from my extruder vendor.

    config-0804.g


  • Moderator

    What are the heaters? What wattage? What voltage are you running?

    What happens when you start tuning from room temp?

    ; Heaters
    M140 H-1                                       ; disable heated bed (overrides default heater mapping)
    M308 S2 P"e1temp" A"Nozzle(1)" Y"thermistor" T4606017 B5848 C5.548428e-8 R4700  ; configure sensor 2 as thermistor on pin e1temp
    M950 H2 C"e1heat" T2                           ; create nozzle heater output on e1heat and map it to sensor 2
    M307 H2 B0 S1.0                               ; disable bang-bang mode for heater  and set PWM limit
    M143 H2 S480
    ;
    M308 S1 P"e0temp" A"Bottom(0)" Y"thermistor" T4606017 B5848 C5.548428e-8 R4700  ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1                           ; create nozzle heater output on e0heat and map it to sensor 1
    M307 H1 B0 S1.0                                ; disable bang-bang mode for heater  and set PWM limit
    M143 H1 S480
    ;
    M308 S0 P"bedtemp" A"Top(b)" Y"thermistor" T4606017 B5848 C5.548428e-8 R4700 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0                          ; create nozzle heater output on bedheat and map it to sensor 0
    M307 H0 B0 S1.0 D120                              ; disable bang-bang mode for heater  and set PWM limit
    M143 H0 S480
    
    
    ; Fans
    M950 F0 C"fan0" Q500                           ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1                                 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500                           ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H1:2 T45                            ; set fan 1 value. Thermostatic control is turned on
    
    ; Tools
    M563 P0 S"pulsar" H0:1:2 D0 F0                 ; define tool 0
    G10 P0 X0 Y0 Z0                                ; set tool 0 axis offsets
    G10 P0 R0 S0                                   ; set initial tool 0 active and standby temperatures to 0C
    
    M501		; load heater tuning info
    

  • administrators

    @Billwhit said in Heater config struggles:

    The sensors are not stable at room temperature

    If you have to start at 75C then IMO you need more suitable sensors. The T value of your sensors (4.6Mohms @ 25C according to your M308 command) is far too high for any 3D printer controller. Are you sure it is correct?

    Thermocouples cover a wide range. You may also be able to find PT100 or PT1000 sensors that go up to 500C.

    As @Phaedrux mentioned, M143 sets the maximum allowed temperature.

    How long does your heater take to reach e.g. 400C ?



  • @Phaedrux
    The heaters are 110VAC controlled by 3 DC-AC SSR relays.
    They are 450,250, and 100 watts, respectively.

    If I start from room temp, we get the "temperature not reached" error.



  • @dc42 They are very stable after 75C but at room temp they flop around to almost +/-15C.

    The TValues were provided by the manufacturer.

    I have only had the patience to get all three of them up to 300C, and that took almost an hour of sitting by the console and resetting the faults. I have made a couple test prints at 250 and the sensors are stable.



  • Setting the max temperature with M143 helped and I am up and running.
    Thanks for the help, and thanks for a great platform.
    --bill


Log in to reply