UNSOLVED M675 probe cavity issues



  • Hi, I am hoping someone can help me with this. I can probe on xyz using m585 with configured endstop, but i cant get m675 to work. This is what my macro looks like,

    G91
    T1
    M675 X10 E3 L0 R2 F500

    When I run the macro the machine starts moving in the -x direction and when i trigger the end stop nothing happens. It wont stop moving on the -x direction until i hit the e stop.

    This is my config.g file
    ; Configuration file for factory testing Duet Ethernet and Wifi with V2.02 firmware
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.4 on Wed Dec 18 2019 20:29:17 GMT+1100 (Australian Eastern Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"cnc" ; set printer name
    M453 ; cnc mode

    ; Network
    M552 S1 ; enable network
    M552 P192.168.0.60 ;
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S0 ; physical drive 2 goes forwards
    M569 P3 S0 ; physical drive 3 goes backwards
    M569 P4 S1 ; physical drive 4 goes backwards
    ;M584 X0:3 Y1:4 Z2 U3 V4 P3 ; set drive mapping
    M584 X0 Y1:4 Z2 V4 P3 ; set drive mapping
    M350 X16 Y16 Z16 U16 V16 I1 ; configure microstepping with interpolation
    M92 X643 Y643 Z400.00 U100 V643 ; set steps per mm
    M566 X600.00 Y600.00 Z12.00 U600.00 V600.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X3000.00 Y3000.00 Z249.60 U2000.00 V3000.00 ; set maximum speeds (mm/min)
    M201 X50.00 Y50.00 Z20.00 U50.00 V50.00 ; set accelerations (mm/s^2)
    M906 X2200 Y2400 Z2400 V2400 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z-80 U0 V0 S1 ; set axis minima
    M208 X555 Y410 Z80 U410 V410 S0 ; set axis maxima

    ; Endstops
    M574 X2 S1 C0 ; set active low and disabled endstops
    M574 Y2 S1 C1 ; set active low
    ,M574 Z1 S0 C2 ; set active low
    M574 Z2 S1 C2 ; set active low
    M574 U1 S0 C3 ; set active low
    M574 V2 S1 C4 ; set active low

    ; Heaters
    M140 H-1 ; disable heated bed

    ; Tools
    M563 P1 D0 ;

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ;
    ; Miscellaneous
    M501 ; load saved parameters from non-volatile memory
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss
    M98 Pcustomconfig.g ;
    T0 ; select first tool
    ; M117 Use https://configurator.reprapfirmware.org/ to set up your printer com


  • Moderator

    @kouta10 said in M675 probe cavity issues:

    M675 X10 E3 L0 R2 F500

    I don't think X10 is correct. It should just be X to denote the X endstop. Not sure where you got L0 and E3 from either.

    https://duet3d.dozuki.com/Wiki/Gcode#Section_M675_Find_center_of_cavity



  • @Phaedrux if i got my x end fixed at low end of axis, how does that work? If cavity is in the middle of the bed, x never gets triggered.



  • The hole idea is to use probe as trigger for cavity, i don't see how that works any other way unless i understood it wrong.


  • Moderator

    Did you correct your M675?

    I'm not sure I understand what you mean.


Log in to reply