Need Help with Panel Due firmware update



  • TLDR My Panel was working, now its black after firmware upgrade attempt.

    I purchased a 7" Panel Due and Due wifi from Filastruder.
    As part of new printer build I first plugged the panel due into the DueWifi and powered the DueWifi via usb.
    The Panel lit up with the initial touch calibration and was displaying realistic temperatures.
    I followed the instruction at https://miscsolutions.wordpress.com/paneldue/
    I downloaded the PanelDue-7.0-1.16.bin file at https://github.com/dc42/PanelDueFirmware
    I installed the bossa-x64-1.8.msi.zip from https://github.com/shumatech/BOSSA/releases. on my 64bit Win7 computer
    I did the erase button and reset and the screen went black. as mentioned for the 2.0
    I chose COM11 and browsed to the PanelDue-7.0-1.16.bin file and hit write. The process appeared to be successful
    I hit the verify button, everything looked ok
    I hit the reset button again on the panel board and the screen did not come back on.
    I ran the command prompt version and it was successful but the screen was still black.
    Com 11 still appeared in device manager as bossac port.
    after a reboot and few unplug & re-plug the usb the com11 did not come back in device manager. there are no unidentified devices in device manager either.
    The jumper on the panel due board is set to 3.3V

    it appears the board is completely dead at this point. Any Ideas?



  • Looks like you may not have downloaded the Firmware file correctly can you confirm that your DL is around the 128K size that it should be?

    Your Bossa is looking like your file is only about 33K


  • administrators

    I agree with Doug, you have probably downloaded the HTML page describing the firmware instead of the firmware binary (a common mistake with using github because users expect links whose text ends in ".bin" to be binaries, not HTML pages). Follow the link and when you get to the page describing just that file, press the Download button.

    To get the Bossa port back,connect the USB cable, press the Erase button for a second or so, followed by the reset button.



  • You guys are great, that is it, my .bin is 34k. What can I do to get the board to reappear in device manager now so I can reflash the correct.bin? I've tried multiple usb ports and rebooting, and "scan for hardware changes".



  • press the erase button for a few seconds and then the reset button and it should appears in DM as a bossa port then flash away



  • SUCESS!

    Thank you all



  • Next hurdle:
    I successfully updated the panelDue firmware, Reprap firmware, wifi firmware, and web console firmware.
    Now when i copy the config.g from https://github.com/mzbotreprap/VORON/tree/master/Firmware/DuetWifi/yonkiman/sys
    the panel due boots up with the expected configuration but the screen flashes on and off. I tried using the corexy config.g supplied by filastruder on the microSD card and get the exact same result. Any Ideas?



  • How are you powering the Duet?



  • I am powering the duet via usb. I tried via "high power" usb port on my laptop and through a powered hub. The screen did not blink with the default kossel configuration file from filastruder



  • USB ports often can't supply enough power for the Duet+PanelDue. The configuration file likely has some differences that result in a different power draw. Best to power using the screw terminals.



  • That was it. I'm powering it from the 24V PS and its solid.



  • Sorry for hijacking this thread, but i've got kinda the same problem.

    Updated FW from 1.15c to 1.16 for the 5" PanelDue. After flash i hit reset. But it stays black and it appears no longer in the device manager. Any way to "jump start" the panel? 😞

    Message in cmd:

    C:\Users\Grafikbitch\Downloads\bossa>bossac.exe --port=COM6 -e -w -v -b PanelDue-5.0-1.16.bin
    Erase flash
    Write 130720 bytes to flash
    [==============================] 100% (511/511 pages)
    Verify 130720 bytes of flash
    [==============================] 100% (511/511 pages)
    Verify successful
    Set boot flash true
    
    C:\Users\Grafikbitch\Downloads\bossa>
    

  • administrators

    That's odd, I can't see anything wrong in your description.

    You can connect the Duet to a PC via USB and run Pronterface or a terminal emulator program on the PC for debugging. If you send M111 S1 P3 to the Duet, it will echo all commands received to the USB port. If you see any lines starting with "aux:" then the PanelDue is sending status requests to the Duet.



  • That's what i thought too 😞

    I turned debugging on an used your mentioned M111 command and there is no line with "aux".

    SENT: M111 S1 P3
    READ: serial: M111 S1 P3
    READ: Debugging enabled for modules: Platform(0) Network(1) Webserver(2) GCodes(3) Move(4) Heat(5) DDA(6) Roland(7) Scanner(8) PrintMonitor(9) Storage(10) PortControl(11) ?(12)
    READ: Debugging disabled for modules:
    READ: ok
    SENT: M105
    READ: serial: M105
    

    The output "READ: serial: M105" then repeats every second or so.

    Tried this with printer normal powered on, turned off and powered over the USB. USB every time connected over the duet to the pc.

    Maybe the output power for the Due is faulty? But on the other hand it will also not turn on when i connect the Due over USB to the PC.


  • administrators

    Try downloading and flashing the firmware again, in case the firmware somehow got corrupted in the process.

    Did you separate the PanelDue controller and the TFT panel at any stage? If so, are you sure that you lined them up properly when you put them back together?



  • No i didn't and now it gets weirder.

    I dissasembled the due controller from the panel, removed the power wire from controller and duet. Re-assembled and… it works ^^

    I don't knwo what the heck happened but all is good πŸ™‚ Maybe it was the dissassembly or the whole day without plugged in while i am at work.

    Thx again πŸ™‚


  • administrators

    I'm glad it's working. I suspect a bad connection.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.