Need Help with Panel Due firmware update

  • How are you powering the Duet?

  • I am powering the duet via usb. I tried via "high power" usb port on my laptop and through a powered hub. The screen did not blink with the default kossel configuration file from filastruder

  • USB ports often can't supply enough power for the Duet+PanelDue. The configuration file likely has some differences that result in a different power draw. Best to power using the screw terminals.

  • That was it. I'm powering it from the 24V PS and its solid.

  • Sorry for hijacking this thread, but i've got kinda the same problem.

    Updated FW from 1.15c to 1.16 for the 5" PanelDue. After flash i hit reset. But it stays black and it appears no longer in the device manager. Any way to "jump start" the panel? 😞

    Message in cmd:

    C:\Users\Grafikbitch\Downloads\bossa>bossac.exe --port=COM6 -e -w -v -b PanelDue-5.0-1.16.bin
    Erase flash
    Write 130720 bytes to flash
    [==============================] 100% (511/511 pages)
    Verify 130720 bytes of flash
    [==============================] 100% (511/511 pages)
    Verify successful
    Set boot flash true

  • administrators

    That's odd, I can't see anything wrong in your description.

    You can connect the Duet to a PC via USB and run Pronterface or a terminal emulator program on the PC for debugging. If you send M111 S1 P3 to the Duet, it will echo all commands received to the USB port. If you see any lines starting with "aux:" then the PanelDue is sending status requests to the Duet.

  • That's what i thought too 😞

    I turned debugging on an used your mentioned M111 command and there is no line with "aux".

    SENT: M111 S1 P3
    READ: serial: M111 S1 P3
    READ: Debugging enabled for modules: Platform(0) Network(1) Webserver(2) GCodes(3) Move(4) Heat(5) DDA(6) Roland(7) Scanner(8) PrintMonitor(9) Storage(10) PortControl(11) ?(12)
    READ: Debugging disabled for modules:
    READ: ok
    SENT: M105
    READ: serial: M105

    The output "READ: serial: M105" then repeats every second or so.

    Tried this with printer normal powered on, turned off and powered over the USB. USB every time connected over the duet to the pc.

    Maybe the output power for the Due is faulty? But on the other hand it will also not turn on when i connect the Due over USB to the PC.

  • administrators

    Try downloading and flashing the firmware again, in case the firmware somehow got corrupted in the process.

    Did you separate the PanelDue controller and the TFT panel at any stage? If so, are you sure that you lined them up properly when you put them back together?

  • No i didn't and now it gets weirder.

    I dissasembled the due controller from the panel, removed the power wire from controller and duet. Re-assembled and… it works ^^

    I don't knwo what the heck happened but all is good πŸ™‚ Maybe it was the dissassembly or the whole day without plugged in while i am at work.

    Thx again πŸ™‚

  • administrators

    I'm glad it's working. I suspect a bad connection.

Log in to reply