BL Touch Assistance



  • I am using a Duet 3 toolboard and having issues getting a BL Touch working. Yes - another BL Touch thread - sorry. I did search (a lot) prior to making this thread. My firmware has been updated to the latest as well as DWC is at 3.1.1.

    I have two BL Touch v3.1 probes that are both exhibiting the same behavior when plugged in (individually) to io0 on the toolboard. They both could be faulty, but I doubt it as this is my first attempt at getting it working. Neither are doing a self-test on boot, but they are responding as described below.

    I am using a Duet 3 toolboard.

    M280 P0 S10 - ejects the pin like it should
    M280 P0 S90 - does nothing and the probe begins flashing red
    M280 P0 S160 - resets the probe like it should

    I've also tried a lot of other values for S, but nothing else works. I've scoured the forums and my current config settings are as follows.

    M558 K0 P9 C"20.io0.in" H5 F100 T2000 A5 S0.02
    M950 S0 C"20.io0.out"
    G31 K0 X28.1 Y-27.5 Z0
    M557 X10:290 Y1:290 S20

    Both probes are behaving in the exact same manor. So either both are defective, or I don't know what I'm doing.. anyone willing to help me out? I'm hoping it's something simple I've missed. Thanks!



  • Forgot to mention - I've tried multiple cables with no success..



  • I've continued to search after posting this to no avail.. decided to go ahead and purchase another BL Touch (genuine - as are the other two) to rule that out. If anyone reads this and has any ideas, I'm all ears.


  • Moderator

    Maybe post a photo of your wiring and probe?
    Post full config.g.



  • @Phaedrux Thanks but it turned out both probes I had on hand were faulty.. ugh. I got this all sorted out when the new one arrived.


  • Moderator

    Thanks for letting us know. Glad you got it sorted out.


Log in to reply