Bltouch Setup Issue



  • Hi,
    Trying to get my bltouch setup on my duet 2 wifi (firmware 3.1.1) for my delta printer. I was able to get the probe to deploy and retract, but the hotend crashes into the bed when the probe is deployed. Probe value stays 0 no matter if retracted or deployed.

    Attaching wiring, config.g, and calibration and compensate gcode below.

    Calibrate and Compensate
    G28 ; home
    M104 S0 ; turn off hot end
    M140 S0 ; turn off bed
    M280 P0 S10 ; deploy BLTouch
    G32 ; auto calibrate
    G29 ; generate bed height map
    G28 ; home
    M280 P0 S90 ; retract BLTouch

    config.g
    ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Mon Aug 10 2020 22:27:49 GMT-0600 (Mountain Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Sandoria Kossel" ; set printer name
    M665 R220 L385 B130 H140 ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; put your endstop adjustments here, or let auto calibration find them

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z80.00 E663.00 ; set steps per mm
    M566 X1200.00 Y1200.00 Z1200.00 E1200.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z18000.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X1000.00 Y1000.00 Z1000.00 E1000.00 ; set accelerations (mm/s^2)
    M906 X1000 Y1000 Z1000 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 Z0 S1 ; set minimum Z

    ; Endstops
    M574 X2 S1 P"xstop" ; configure active-high endstop for high end on X via pin xstop
    M574 Y2 S1 P"ystop" ; configure active-high endstop for high end on Y via pin ystop
    M574 Z2 S1 P"zstop" ; configure Z-probe endstop for low end on Z

    ; Z-Probe
    M950 S0 C"exp.heater3" ; create servo pin 0 for BLTouch
    M558 P9 C"^zprobe.in" H5 F120 T6000 ; set Z probe type to bltouch and the dive height + speeds
    G31 P500 X0 Y0 Z2.5 ; set Z probe trigger value, offset and trigger height
    M557 R85 S20 ; define mesh grid

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M307 H0 B1 S1.00 ; enable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M308 S1 P"e0temp" Y"thermistor" T100000 B4138 ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H1 T45 ; set fan 1 value. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined

    ; Miscellaneous
    M575 P1 S1 B57600 ; enable support for PanelDue
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss

    ![1_1597253175153_IMG_3976.jpeg](Uploading 100%) ![0_1597253175152_IMG_3975.jpeg](Uploading 100%) IMG_3975.jpeg

    IMG_3976.jpeg



  • @Dataro81 It's hard to see, but I think I only see one pin between the ground wire and the heater3 wire on your pic - should be 2 pins in-between.
    blt.jpg



  • @Kolbi Hi, I have two pins in between. Do my configs look correct?

    IMG_3983.jpeg


  • Moderator

    Config looks ok, except

    G31 P500 X0 Y0 Z2.5

    Change P500 to P25, and measure your X Y Z offset.

    https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe

    For the failure to trigger problem that would indicate an issue with your white wire. Check continuity.



  • Thanks @Phaedrux . Will go through your suggestions later today. Back to back meetings all day...



  • @Phaedrux Woot! The code change fixed my issue! Had to lower my bltouch a little so the hotend didn't hit the bed first, but other than that it worked like a charm. Thanks for all the help today!!


Log in to reply