Newbie connecting Workbee Duet 2 via Ethernet To MacBook Pro



  • Can anyone help please? Having built Workbee am trying to connect Duet via Ethernet cable and Thunderbolt to Gigabyte Adapter to MacBook Pro. USB setup worked fine, however having removed USB connector and connected Ethernet cable and powered Duet, again all fine and M552 command confirms Network enabled and connected to correct IP address - however, when I open Chrome and enter IP address assigned to Duet, whilst the comms lights flash on the Duet board Ethernet connector, the Mac reports “This site cannot be reached” !! Can anyone shed any light as to my error(s) ? Thank you


  • Moderator

    @kbjpick The Duet is usually connected into your network, eg to your network router, and devices connected to your network can connect to the Duet. Are you trying to connect the Duet directly to your Mac, ie ethernet cable from Duet straight into Mac, not into your network router? If so, you need to set up the Duet and the Ethernet adapter on the Mac in a specific way. It's documented here, though the example is for Windows: https://duet3d.dozuki.com/Wiki/Setting_up_networking_on_Duet#Section_Wired_direct_connection

    If that's what you're trying to do, and need more help/direction, let me know.

    Ian



  • Many thanks for alacrity of response. Yes, I am trying to connect Duet directly into MacBook as Wi-Fi is non-existent at location of Workbee. The need to use an adapter as the MBP does not have an Ethernet port exacerbates confusion for me. I will examine the guide you have identified overnight and see if it becomes clearer. I appreciate your help - Ken


  • Moderator

    @kbjpick Is your Mac connected to your network via WiFi? Check by going to System Preferences > Network. The network connections will be listed on the left:
    d73a71d8-cf53-4683-8a7d-e016c157ed71-image.png
    Highlight the network connection, and it will tell you the IP address that has been assigned under 'Status'. Mine is connected by WiFi, and has an IP address of 192.168.0.14. You can click on 'Advanced' then TCPIP to see the full details, including subnet mask and router address:
    e28cc380-5e73-47a3-9af3-ab20a05b7997-image.png

    You should have a wired Ethernet connection in your network connections list, that you're going to use to connect to the Duet. Select this, then click 'Advanced'. This is where you set the IP address for that network connection, and make it different from your existing network address, as per the guide. Then change the network settings in config.g on the Duet.

    Let me know if that's not clear.

    Ian



  • Ian - slow response from me I'm afraid as I get confused easily these days! Answering your question - yes Mac IS connected to Wifi and identifies address of MBP (MacBook Pro) as 192.168.1.125. The 'Advanced' tab further identifies the Subnet Mask as 255.255.255.0 and the router as 192.168.1.254.
    Going to an earlier process - connection of the USB cable alone and using Terminal and M115 identifies the Firmware as V 2.03, i.e the Duet boars IS responding. M552 returns an IP address (I am assuming of the Duet board ?) of 192.168.1.14
    Using Terminal on the MBP i.e. ipconfig getifaddr en0 returns the IP address of the MBP as 192.168.1.125 as above.
    The Thunderbolt Ethernet connection connects with 'Configure Ipv4: Using DHCP using address 169.254.79.162 Subnet Mask 255.255.0.0
    Is this where I should enter an IP address via the Configure IPv4: Manually ?
    and if so - whilst you say make it different - the guides are unclear as HOW different!
    I acknowledge my unfamiliarity with Mac and addresses but the next step seems to be buy a Windows computer as the guides seem simpler. From the above are you able to a/ confirm I need enter an IP address via the Configure IPv4: Manually boxes and b/ what address do I enter into Chrome to gain access to the Webcontrol page? With the Ethernet cable connected the Terminal commands return "command not found" so I can't even see the Duet board at all. Very complicated for a Newbie. Thanks for any light you are able to shed on this - thanks Ken



  • @kbjpick said in Newbie connecting Workbee Duet 2 via Ethernet To MacBook Pro:

    The Thunderbolt Ethernet connection connects with 'Configure Ipv4: Using DHCP using address 169.254.79.162 Subnet Mask 255.255.0.0

    You'll either need to assign the Duet an IP address in this range, or use another range that differs from the one you use for Wifi if you want a direct connection. if the Duet is the sole purpose of the external ethernet on the Mac then I'd set a network for it. Say IP 192.168.2.2 netmask 255.255.255.0 for the Mac.

    Then configure the Duet to use IP 192.168.2.3 with M552 S1 P192.168.2.3 and connect to http://192.168.2.3/ from your Mac once the link is established. If you're still having issues share the output of ifconfig for the external thunderbolt network when the Duet is connected and powered on.

    edit: changed subnet due to ambiguity in previous post internal malfunction.



  • Hi - thank you for your input - I am away from the house for 10 days from tonight and will implement your suggestions on my return and revert with the findings - again many thanks and will liaise on my return. I have tried to re-assure myself that the board IS working and am also trying to identify what all the LEDs mean! In the land of the blind etc...



  • @kbjpick said in Newbie connecting Workbee Duet 2 via Ethernet To MacBook Pro:

    also trying to identify what all the LEDs mean!

    https://duet3d.dozuki.com/Wiki/Hardware_Overview#Section_LED_indications
    (i only recently found this myself, well hidden gem:)

    Also don't worry about time; as long as you're happy with the time it takes its all good - no one have any expectations of you to resolve anything in any particular time frame.


  • Moderator

    @kbjpick said in Newbie connecting Workbee Duet 2 via Ethernet To MacBook Pro:

    The Thunderbolt Ethernet connection connects with 'Configure Ipv4: Using DHCP using address 169.254.79.162 Subnet Mask 255.255.0.0
    Is this where I should enter an IP address via the Configure IPv4: Manually ?
    and if so - whilst you say make it different - the guides are unclear as HOW different!

    Yes, that's right, select 'Manually' from the drop down list next to Configure IPv4. You only need to enter the IP address and subnet mask.

    Your current (WiFi) network IP address is 192.168.1.125 with a subnet mask of 255.255.255.0. The subnet mask means that any time you try to connect to a device, and use an IP address where the first three numbers match yours (ie 192.168.1.xxx), it tries to connect to your network.

    Your Thunderbolt Ethernet connection needs a different network 'identity', so that when you type in an IP address, it doesn't get sent via your WiFi network, but to the Thunderbolt Ethernet. By setting this adaptor's IP address to something different from your existing network, and importantly at least one different number in the first three, any IP address in the same range will be routed to the Thunderbolt Ethernet rather than WiFi. See @bearer's suggestions further up, which should work fine (now they're correct!)

    Ian



  • @bearer Having returned to home turf, I have spent afternoon trying suggestions listed above. Summary is that whilst I can see the UNPOWERED Duet via 'System Information' when connected via simple USB - but not when I then connect to the powered Duet via either a USB/Ethernet or a Thunderbolt/Ethernet connector!
    Workbee with USB Connected shows Duet.png
    Workbee with Thunderbolt Ethernet connected does NOT show Duet.png
    You suggested "share the output of ifconfig for the external thunderbolt network when the Duet is connected and powered on." `and I have attached the file recording the result and hope this makes more sense to you than it does to me! Result of ifconfig with Thunderbolt to Gig Ethernet Adapter and Duet connected.docx
    The final item of information is that given there are four (4) connectors to the motors at the top of the Duet board, only three (3) of them illuminate when power is applied? The Y axis Right does NOT illuminate. The other three go out when the relevant limit switch is operated - I'm not sure why one should be out when the other three are on, but I can't see how this would effects the comms?

    Please accept my thanks to all of you who are contributing to my education. Ken


  • Moderator

    @kbjpick the ifconfig doesn’t show the IP address you’ve set for the gigabit Ethernet adapter. Set it to 192.168.2.2 with subnet mask of 255.255.255.0. Plug Ethernet cable into Duet and Mac, and plug in USB to Duet and Mac. This should power up the Duet. Connect to Duet via USB with serial terminal and send M552 P192.168.2.3 S1 which sets the Duet IP address. Then open a browser window on the Mac and type 192.168.2.3 into the address bar. This should connect you to DWC. If so, you can edit the config.g to set the Duet IP address permanently.

    Ian


  • Moderator

    @kbjpick said in Newbie connecting Workbee Duet 2 via Ethernet To MacBook Pro:

    The final item of information is that given there are four (4) connectors to the motors at the top of the Duet board, only three (3) of them illuminate when power is applied? The Y axis Right does NOT illuminate. The other three go out when the relevant limit switch is operated - I'm not sure why one should be out when the other three are on, but I can't see how this would effects the comms?

    That's all normal, Those are the endstop lights. XYZ. The E endstops aren't used for normal motion endstops.

    Carry on with configuration and when you get to testing endstops with actual switches connected see if you actually have an issue.

    https://duet3d.dozuki.com/Wiki/Connecting_endstop_switches



  • @droftarts Following latest instructions - Query why or what does having the Ethernet cable connecting Duet and Mac as above actually do when mains power is not connected?
    However, as instructed, I left the Ethernet cable connected and I plugged in the USB to Duet and Mac and the Duet duly powered up and confirmed that sending M552 P192.168.2.3 S1 had changed the Duet IP address to 192.168.2.3 by querying with M552. So far so good!
    So, I now have the Ethernet connected to the Mac and Duet as well as the USB connection but with no mains power given stricture of not having mains power connected when USB connection is made between Duet and computer.
    Again, following your instructions, I open Chrome browser on Mac and enter 192.168.2.3 into the address bar - no connection and search times out. The Firewall is not activated and there are no Proxies.
    I tried this with another MacBook with same results.
    Precis - I can change IP on Duet but still am unable to connect to it to change config. g file - with apologies for verbosity to avoid confusion - any suggestions please. Ken


  • Moderator

    @kbjpick the Ethernet will work under USB power. Once the Duet is set up and working you can disconnect USB and connect mains power.

    You temporarily changed (until the next power cycle) the Duet IP address with M552, but how is the Mac Ethernet adapter set up? I can see you have set it to something in this image:
    alt text
    But the actual numbers are obscured by the window on top. IP address for this should be 192.168.2.2, subnet mask 255.255.255.0.

    Once this is done, then connect the Duet by USB and Ethernet, change the Duet IP address with M552 again, and attempt to connect with the browser once more.

    If you can get DWC running, you can edit the config.g, putting in the Duet IP address, to make this set up permanent.

    Ian



  • Thanks again for your patience - completed instructions as above and confirmed via M552 that network IS operative and Duet address is as follows " Network is enabled, configured IP address: 192.168.2.3, actual IP address: 192.168.2.3
    ok"
    However, when using chrome and entering "192.168.2.3" into search bar, I receive the following message "This site can’t be reached192.168.2.3 took too long to respond.
    Try:
    Checking the connection
    Checking the proxy and the firewall
    ERR_CONNECTION_TIMED_OUT"

    As I commented in an earlier post, The Firewall is not activated and there are no Proxies, and I have tried this with another MacBook with same results. Is there anything further I can attempt. Regards Ken


  • Moderator

    @kbjpick Can you post a picture of the network settings for you Mac Gigabit Adapter? Should look something like this:

    b33d558e-3a79-4349-beea-beb95f6599d6-image.png

    Ian



  • @droftarts Thanks for quick reply, please see screen dump of your request and snapshot of my relevant network page

    2848269E-2ED3-4DE2-B784-3EB320BB15ED.jpeg

    It appears identical. Ken


  • Moderator

    @kbjpick Okay, that looks correct, and actually shows as 'connected'. After you are sure the Duet's IP address is set to 192.168.2.3 again with M552, and the Ethernet cable is plugged directly from Duet to Mac, can you open a Terminal window on your Mac (Applications > Utilities > Terminal) and type ping 192.168.2.3? Let it run for 10 seconds, then Control-C to stop it. This should give you something like (this was to a Duet 2 Ethernet on my network):
    80d26b11-58c2-4835-aec6-3739d07869e0-image.png
    If you get lots of 'Request timeout for icmp_seq 0' messages, then it's not seeing the Duet for some reason. If it does ping correctly, it is seeing it, but it's either not reading the SD card, or the www folder on the SD card is empty. So next thing is to show a directory listing of the SD card, eg:
    dba309ba-8573-4078-8c57-30bdf530ceaf-image.png

    Ian



  • @droftarts said in Newbie connecting Workbee Duet 2 via Ethernet To MacBook Pro:

    ping 192.168.2.3

    Ian, have attached screen dump of Terminal confirming via M552 that the Duet's IP address is set to 192.168.2.3. Running ping 192.168.2.3 produces display on Terminal of "Bad command: ping 192.168.2.3" Does this help?
    58EF1826-FEFD-4989-BAF8-A9AF23715532.jpeg
    Ken


  • Moderator

    @kbjpick You send ping from the Mac terminal, not in the 'screen' serial terminal connected to the Duet. Start a new Terminal window (Command-n), then type ping 192.168.2.3.

    Could you take a picture of how the Ethernet cable is connected between the Duet and Mac, just in case we're missing something obvious?!

    Ian



  • @droftarts said in Newbie connecting Workbee Duet 2 via Ethernet To MacBook Pro:

    ping 192.168.2.3

    My Mac/Apple education is leaping ahead! I never knew that there was more than one 'Terminal'! I am also appreciating the need to be LITERAL in reading instructions - Command n does not open a Terminal window - but 'Command-n' does! I have attached E579F503-EB44-41AB-9CBF-5FC91AB9A8DA.jpeg the result of the ping 192.168.2.3 command. Even to my uneducated eye it appears something is awry? Ken



  • Ian photos of connections as requested
    IMG_2502.jpeg IMG_2501.jpeg
    Ken


  • Moderator

    @kbjpick hmm, yes, the ping response shows no connection. And you hadn’t turned off the Duet, so it’s IP address is still 192.168.2.3?

    Do you have a spare Ethernet hub you can cable between the Duet and Mac? It’s possible the auto negotiation isn’t working between the two, and even a simple hub can force the right speed.

    Ian



  • Ian Exposing all my ignorance here I know but, not sure what an ethernet Hub is? Google suggests one of these "TP-Link TL-SG105S 5-Port Desktop Gigabit Ethernet Switch/Hub, Ethernet Splitter, Plug & Play, no configuration required,' so have ordered it on Prime for delivery tomorrow. If this is not what you meant, please advise and I will order one. Ken


  • Moderator

    @kbjpick said in Newbie connecting Workbee Duet 2 via Ethernet To MacBook Pro:

    5-Port Desktop Gigabit Ethernet Switch

    That should do it.


Log in to reply