Stall detection fails after calibrating steps/mm



  • Hello! I have been doing some calibrations on my CoreXY printer and I have ran into some issues with my sensorless homing setup.

    I simply can't get the stall detection to work after changing the steps/mm on each motor for X and Y.

    I used this before the calibration:

    M92 X80.00 Y80.00 Z400.00 E2771.50
    

    And changed it to this:

    M92 X79.24 Y79.64 Z400.00 E2771.50
    

    Stall detection settings:

    M915 X Y S3 F0 H300 R0
    

    The stall detection works perfect with 80 steps/mm but with the lower ones(79.**) does not make the stall detection trigger at all. I have tried to change up the S parameter all the way down to -50 but there are no visible changes. The motors drag the extruder to the end of its axis and the belts start slipping.

    I can't find anything about this in the limitations section of stall detection. Is there anything im missing here?

    Thanks!


  • administrators

    What speed do you use in the homing move? How does the minimum speed for stall detection reported by M915 compare with that speed?



  • @dc42 Im running it on 3600.

    My homing file looks like this:

    ; homeall.g
    ; called to home all axes
    ;
    
    M400                    	; make sure everything has stopped before we make changes
    M913 X50 Y50	       		; reduce motor current to 50% to prevent belts slipping
    G91                     	; use relative positioning
    G1 S1 X-400	F3600	 		; move back 400mm, stopping at the endstop
    G1 X5	           			; move away from home
    G1 S1 Y-400 F3600		 	; move back 400mm, stopping at the endstop
    G1 Y5	           			; move away from home
    G1 S1 X-400	F3600			; move towards axis minimum
    G1 S1 Y-400	F3600			; move towards axis minimum 
    G1 X5 Y60	                ; move away from home
    G92 X0 Y0					; set coordinates to 0,0
    M400                    	; make sure everything has stopped before we reset the motor currents
    M913 X100 Y100		     	; motor currents back to normal
    
    ;G90                     	; absolute positioning
    ;G1 X0 Y60 F6000          	; go to first bed probe point and home Z
    ;G30                     	; home Z by probing the bed
    
    

    M915 reports:

    M915
    Driver 0: stall threshold 3, filter off, steps/sec 300, coolstep 0, action: none
    Driver 1: stall threshold 3, filter off, steps/sec 300, coolstep 0, action: none
    Driver 2: stall threshold 1, filter off, steps/sec 200, coolstep 0, action: none
    Driver 3: stall threshold 1, filter off, steps/sec 200, coolstep 0, action: none
    Driver 4: stall threshold 1, filter off, steps/sec 200, coolstep 0, action: none
    

  • administrators

    You are running older firmware, so M915 is not translating the full steps/sec into mm/sec. However, we can do that by hand. Assuming you are using x16 microstepping, 300 full steps/sec is 4800 microsteps/sec, divided by 80 steps/mm is 60 mm/sec, times 60 is 3600 mm/min. So your homing speed is exactly the same as the minimum stall detection speed. When you reduce the steps/mm, the minimum stall detection speed is slightly higher than your homing speed.

    So you need to reduce the M915 H parameter.



  • @dc42 I will update the firmware right away. Been a while sinse I updated last.

    Thanks alot for the explanation. You were 100% right! I was a bit too quick to overlook that 🤠

    It triggered right away when I reduced the H parameter.

    Thanks again 🙂


Log in to reply