Limit Switch Trouble



  • Hi I'm having trouble with my limit switches. I'm using the makerbot switch's, I made sure the wires are connected correctly and I'm using RepRapFirmware 3.
    The problem is that when I run the home command, it does nothing unless I close the limit switch, then it will home until I release the switch, they are working backwards. When I close the switch, the light comes on just like it should. I have tried it with it set to both active high and active low, I even went into the config file to confirm whether or not a ! was in front of the pin name, ! for active low and nothing for active high.
    What is going on? I have used the Duet 2 wifi before (which is what I'm using) and never had this problem before even with the very same limit switches. It started doing it with my original board, at first I though maybe I had the wires wired up wrong and maybe that damaged the board, so I bought a new board but it does the same thing.


  • Moderator

    Please post your config file.
    Confirm that you have firmware 3.1.1 installed by sending M115.



  • @amostol said in Limit Switch Trouble:

    makerbot switch's

    ; Endstops
    M574 X2 S1 P"!xstop"
    M574 Y2 S1 P"!ystop"

    That is my set up.



  • Here is my config file

    ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Wed Aug 19 2020 16:46:44 GMT-0700 (Pacific Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"My Printer" ; set printer name

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P8 S1 ; physical drive 8 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X8 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E420.00 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z1800 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X485 Y485 Z485 S0 ; set axis maxima

    ; Endstops
    M574 X2 S1 P"!xstop" ; configure active-high endstop for high end on X via pin xstop
    M574 Y2 S1 P"!ystop" ; configure active-high endstop for high end on Y via pin ystop
    M574 Z2 S1 P"!zstop" ; configure active-high endstop for high end on Z via pin !zstop

    ; Z-Probe
    M558 P1 C"zprobe.in" H5 F120 T6000 ; set Z probe type to unmodulated and the dive height + speeds
    G31 P500 X0 Y0 Z2.5 ; set Z probe trigger value, offset and trigger height
    M557 X15:215 Y15:195 S20 ; define mesh grid

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M307 H0 B1 S1.00 ; enable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M308 S1 P"e0temp" Y"thermistor" T100000 B4138 ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H1 T45 ; set fan 1 value. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined



  • @amostol can you post the first few lines of m122 ?
    You may be on version 3 config , but are you on version 3 firmware ?

    m122
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 3.1.1 running on Duet WiFi 1.02 or later
    Board ID: 08DGM-95BLL-N6PSS-6JTD6-3SJ6K-K0UZJ
    Used output buffers: 3 of 24 (21 max)


  • Moderator

    @amostol Can you show a picture of the wiring, on the endstop switch and on the Duet? If you send M119, what does the endstops report when not pressed? While our guide here https://duet3d.dozuki.com/Wiki/Connecting_endstop_switches#Section_Makerbot_Mechanical_Endstop_v1_Num_2 says to invert these endstops with '!', it may be that you have a version that does not need inversion.

    As others have already said, please post your firmware version.

    Ian



  • It says
    "RepRapFirmware for Duet 2 WiFi/Ethernet version 2.05.1 running on Duet WiFi 1.02 or later
    Board ID: 08DJM-9178L-L2MS8-6J1FL-3SN6N-KVFYR
    Used output buffers: 3 of 24 (10 max)"
    I just updated it to 3, I do not understand why it is saying version 2, I guess I'll have to try updating again.

    I have tried it without the ! and it makes no difference. Thanks for the help.


  • Moderator

    @amostol said in Limit Switch Trouble:

    I just updated it to 3, I do not understand why it is saying version 2, I guess I'll have to try updating again.

    That explains it. Your config is for RRF3 but your firmware is still RRF2.

    You'll need to update to 3.0 and then 3.1.1. Perhaps you tried to go straight to 3.1.1?

    Easiest way is to upload the entire 3.0 zip file as is (don't extract it yourself) to the /sys folder via DWC. It should be detected and automatically update everything needed.

    Then do the same thing with the 3.1.1 zip file.

    https://github.com/Duet3D/RepRapFirmware/releases/download/3.0/Duet2and3Firmware-3.0.zip

    https://github.com/Duet3D/RepRapFirmware/releases/download/3.1.1/Duet2and3Firmware-3.1.1.zip



  • @amostol
    Looks like I was spot on that you have config.g / firmware mismatch.

    Upgrade to version 3 or use the version 2 configurator



  • I updated it and now it works, I most have done something wrong the first time I tried to update it.

    Thanks for your help, I really appreciate it.


Log in to reply