Duet 3 chamber heater setup issue



  • I am trying to get my chamber heater working on my Duet 3. I am using an SSR and if I provide the SSR with voltage it triggers and the heater works. When I try to activate it with DWC, it just faults because there is no change in temp and I get the rising too slowly error.

    Here is the relevant section of my config file on the chamber heater:

    M308 S3 P"temp3" Y"pt1000" R2200 ; configure sensor 3 as PT1000 on pin temp3
    M950 H3 C"out3" T3 ; create bed heater output on out0 and map it to sensor 3
    M141 H3 ; Define heater h3 as chamber heater
    M301 H3 P-1 ; Disable PID settings to use bang-bang
    M143 H3 S150 ; set temperature limit for heater 3 to 150C

    I am using Duet Web Control 3.1.1. Note the temp is correct and reflects change if you manually cycle the ssr.

    temps.PNG

    Any suggestions would be appreciated.

    Thanks,

    Mark


  • Moderator

    Have you tried to PID tune the heater yet? If you can get it to tune it will have a model of its performance and won't error anymore.

    Chambers are tricky though because they heat so slowly, it's difficult to know if it's actually heating or if there is a fault.

    Where is your thermistor located? The closer the sensor is to the heater the tighter the control loop.

    If it can't auto tune, you can derive your own PID values.

    Have you seen these?

    https://duet3d.dozuki.com/Wiki/Connecting_and_configuring_a_chamber_heater

    https://duet3d.dozuki.com/Wiki/Tuning_the_heater_temperature_control



  • I tried to tune as you suggested:

    tuning.PNG

    The SSR has an LED that lights when it is activated and it didn't turn on during tuning. It will activate if I supply voltage to the terminals so I verified it works.


  • Moderator

    Post your full config please.

    Also what wires go where on your duet 3? Post a photo?


  • administrators

    Try using M307 to increase the dead time parameter to 60 seconds before tuning.



  • I switched from out3 to out7 and mapped it per config file below and it works. I am not sure why but at least the chamber heater works now and I was able to tune it.

    ; Configuration file for Duet 3 (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Thu Aug 13 2020 09:44:43 GMT-0700 (Pacific Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Duet 3" ; set printer name
    M669 K1 ; select CoreXY mode

    ; Drives
    M569 P0.0 S1 ; physical drive 0.0 goes forwards
    M569 P0.1 S1 ; physical drive 0.1 goes forwards
    M569 P0.2 S0 ; physical drive 0.2 goes backwards
    M569 P0.3 S1 ; physical drive 0.3 goes forwards
    M569 P0.4 S1 ; physical drive 0.4 goes forwards
    M584 X0.0 Y0.1 Z0.2 E0.3:0.4 ; set drive mapping
    M350 X16 Y16 Z16 E16:16 I1 ; configure microstepping with interpolation
    M92 X160.00 Y160.00 Z640.00 E822.67:822.67 ; set steps per mm
    M566 X600.00 Y600.00 Z300.00 E3600.00:3600.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X120000.00 Y120000.00 Z1200.00 E4800.00:4800.00 ; set maximum speeds (mm/min)
    M201 X800.00 Y800.00 Z30.00 E80.00:80.00 ; set accelerations (mm/s^2)
    M906 X1800 Y1800 Z3200 E1800:1800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S20 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X450 Y280 Z320 S0 ; set axis maxima

    ; Endstops
    M574 X2 S1 P"io1.in" ; configure active-high endstop for high end on X via pin io1.in
    M574 Y1 S1 P"!^io2.in" ; configure active-high endstop for low end on Y via pin !^io2.in
    M574 Z1 S2 ; configure Z-probe endstop for low end on Z

    ; Z-Probe
    M558 P5 C"^!io3.in" H2 F150 T1800 ; set Z probe type to switch and the dive height + speeds
    M558 H2 ;*** Remove this line after delta calibration has been done and new delta parameters have been saved
    G31 P1000 X0 Y0 Z0.722 ; set Z probe trigger value, offset and trigger height
    M557 X0:450 Y20:280 S20 ; define mesh grid

    ; Heaters
    M308 S0 P"temp0" Y"pt1000" R2200 ; configure sensor 0 as PT1000 on pin temp0
    M950 H0 C"out0" T0 ; create bed heater output on out0 and map it to sensor 0
    M307 H0 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M143 H0 S170 ; set temperature limit for heater 0 to 170C
    M308 S1 P"temp1" Y"pt1000" R2200 ; configure sensor 1 as PT1000 on pin temp1
    M950 H1 C"out1" T1 ; create nozzle heater output on out1 and map it to sensor 1
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit
    M143 H1 S450 ; set temperature limit for heater 1 to 450C
    M308 S2 P"temp2" Y"pt1000" R2200 ; configure sensor 1 as PT1000 on pin temp1
    M950 H2 C"out2" T2 ; create nozzle heater output on out1 and map it to sensor 1
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit
    M143 H2 S450 ; set temperature limit for heater 2 to 450C
    M308 S3 P"temp3" Y"pt1000" R2200 ; configure sensor 3 as PT1000 on pin temp3
    M950 H3 C"out7" T3 ; create bed heater output on out7 and map it to sensor 3
    M141 H3 ; Define heater h7 as chamber heater
    M301 H3 P-1 ; Disable PID settings to use bang-bang
    M143 H3 S150 ; set temperature limit for heater 3 to 150C

    ; Fans

    ; Tools
    M563 P0 S"Mosquito Main 0" D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C
    M563 P1 S"Mosquito Support 1" D1 H2 F0 ; define tool 1
    G10 P1 X16.150 Y2.15 Z0 ; set tool 1 axis offsets
    G10 P1 R0 S0 ; set initial tool 1 active and standby temperatures to 0C

    ; Custom settings are not defined

    ; Miscellaneous
    M575 P1 S1 B57600 ; enable support for PanelDue
    M501 ; enable config override

    M572 D0 S0.7 ; enable pressure advance


Log in to reply