Duet3 Error: short-to-ground reported by driver 0, 1 and 5



  • Hello. I scanned the forum for similar issues and started my debugging process by we wiring everything once I red that crimps maybe the issue but then it occurred to me that I can simply check each axis on the working drives and the end result is that nothing works on drivers 0, 1 and 5, everything work on 2, 3, 4.

    When X (drive 0) report's an error I pulled it's plug from the board (power off) and connected it to drive 3 (which was supposed to be my U), moved U everything works. Tried with all axis - the only variable was the drive, cables remained the same.

    It's a freshly unpacked board and I was extra careful to check phases and connect everything right (it's the 14th printer I'm building).

    Debug information:
    I'm using Chinese 17HS4401S Nema 17 motors
    Number of Phase: 2.
    Step Angle: 1.8°.
    Phase Voltage: 2.6Vdc.
    Phase Current: 1.7A.
    Resistance/Phase: 1.5Ω ±10%.
    Inductance: 2.8mH ±20% (1KHz).

    ; Drives
    M569 P0.0 S1                                            ; physical drive 0.0 goes forwards
    M569 P0.1 S1                                            ; physical drive 0.1 goes forwards
    M569 P0.2 S0                                            ; physical drive 0.2 goes backwards
    M569 P0.3 S1                                            ; physical drive 0.3 goes forwards
    M569 P0.4 S1                                            ; physical drive 0.4 goes forwards
    M569 P0.5 S1                                            ; physical drive 0.5 goes forwards
    M584 X0.0 Y0.1 Z0.2 U0.3 E0.4:0.5                       ; set drive mapping
    M350 X16 Y16 Z16 U16 E16:16 I1                          ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z800.00 U80.00 E439.271723:439.271723 ; set steps per mm
    M566 X400.00 Y400.00 Z12.00 U400 E120.00:120.00         ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 U6000.00 E1200.00:1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 U500.00 E250.00:250.00       ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 U800 E800:800 I30                    ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                                 ; Set idle timeout
    
    [...]
    
    M564 S0 H0
    M302 P1
    

    Tried with sensorless homing on and off.

    One interesting thing is that when I connected a spare motor (same as the others) to X and set it to M350 X4 it did spin but in random directions, i.e. 3 times clockwise, 1 time counter-clockwise, while I was pressing X+10 on the Web UI while spinning it was also reporting the nasty short-to-ground error.

    I humbly ask for guidance.





  • Thank you very much. I promise I spent like 3 hours googling. Maybe that post should be somewhere in the docs?

    I have precisely the board from the faulty series.

    Thanks again, this is resolved.


Log in to reply