SOLVED Filament Sensor not reporting data



  • I have a Bigtreetech smart filament sensor and am having difficulty getting it to work. I've read multiple posts and tried various settings but but no luck .... help 🙂

    I have wired it into the E0 endstop. Manually (by hand) pulling filament through the sensor causes the E0 endstop LED to turn on / off at (more-or-less) the advertised 7mm sensitivity.

    I (currently) have the following code in config.g

    ; Custom settings
    M591 D0 P7 C"e0stop" L7 R75:125 E22 S1      ;BTT
    

    I have tried various ranges for R and E .

    When trying to print a job - M591 D0 reports the settings but "no data received". I can see the E0 endstop LED responsing to the filament movement.
    After a short while -- the print stops complaining of no movement ......

    I'm using RRF3 and the following:
    Board: Duet 2 WiFi (2WiFi)
    Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 3.1.1 (2020-05-19b2)
    Duet WiFi Server Version: 1.23

    Any and all suggestions appreciated.



  • So it turns out that I am not to be trusted ..... I got "switched around" with the E0/E1 connectors and LED's.

    All good now ... sorry for the false alarm.


Log in to reply