M303 every time?? Also, save home settings?



  • Hi there. New here. I recently installed a Duet Wifi to my Ender 3 V2, which was a great upgrade. I've done several prints with great results, but I have a couple of annoyances. I've searched through the forum and via google and can't seem to figure out how to fix these things unfortunately.

    Duet 2 Wifi board
    Reprap 3.1.1
    Ender 3v2
    I'veupgraded the springs and moved the extruder over to 'direct drive'
    All else is stock parts
    Cura 4.6 - set to reprap
    Using the web interface

    First Issue. Every time I start the machine, if I don't send M303 to tune the bed heater, it throws a fault. Sometimes it's a slow heating fault, sometimes a curve fault, but 99% of the time, it'll fault. Unless I do the M303, afterwhich it works just fine until I power down again. I've also saved the output with M305 to no avail. I'm not sure what to do next.

    And the other bit. Every time I reconnect the machine, I have to rehome axis before I can do anything, even though my codes are set up to home with each print, etc. I couldn't seem to find a way to save this in some way?

    Thanks so much for everyone being here! I've heard really great things about this community, which is one of the factors in me going with this hardward!



  • @Kediil said in M303 every time?? Also, save home settings?:

    I've also saved the output with M305 to no avail. I'm not sure what to do next.

    did you put that M305 in your config g at the correct place?

    And the other bit. Every time I reconnect the machine, I have to rehome axis before I can do anything,
    whats your idle timeout?



  • @Veti I setup the board with the configurator, so I didn't do anything manually. Tech, I'm pretty good with, codey things, a bit less so. 😕

    Edit// Corrected config.g file

    I had previously used the M500 command that sent it to the override, but went back through the guide I had followed and saw that I missed setting it manually as prefered. I think I did it right.

    [0_1600078269035_config.g](Uploading 100%)

    I'm not sure how to check idle time?



  • in the configurator select

    Read config-override.g file at end of startup process

    then after pid tuning issue the command M500. that will save them for you.

    post your config.g


  • Moderator

    https://duet3d.dozuki.com/Guide/Ender+3+Pro+and+Duet+Maestro+Guide+Part+4:+Calibration/40#s161

    Tune it, M500 to save it to config-override.g and then add M501 at the end of config.g to load config-override at boot.

    @Kediil said in M303 every time?? Also, save home settings?:

    And the other bit. Every time I reconnect the machine, I have to rehome axis before I can do anything, even though my codes are set up to home with each print, etc. I couldn't seem to find a way to save this in some way?

    Not sure what you mean here. When the power is removed the motor positions can no longer be guaranteed, so you need to rehome. What do you mean by reconnect?



  • @Phaedrux

    To be more precise. The printer homes before each job starts anyhow. Is there a way to be able to start a job without having to manually home via the web interface, since it's going to home anyhow. Because as of now, I can't start or send a job to the printer without homing the axis, then they home again when it starts.

    I suppose if nothing else, something that will make the machine auto home on each startup? Because sometimes I start the app, then come back a few minutes later and have to home. I mean, the 30 odd seconds isn't going to kill me or anything, but it'd be nice not to have it!


  • Moderator

    You'd have to post your slicer start gcode. Are you getting error messages when you start a print? If there is a G28 in your slicer start gcode before any axis are moved you should be fine.

    There's nothing requiring you to home the printer before starting a print as long as you're not trying to move an axis before the axis has been homed.

    Post a sample gcode maybe?



  • @Veti Apologies, I did try to post the config file before, it even says it up there, but it just put in the words and not the file!

    Let's see if this works. I redid the configurator to activate the override, then retuned and submitted the m500 commands.

    config.g.txt
    config-override.g.txt

    @Phaedrux

    Honestly, I just sent another print to it, and it started fine without homing. So I don't know if it was fluking on me, or if I changed something when I redid the configurator. But either way, I'm not complaining!


  • Moderator

    G31 P500 X0 Y0 Z2.5 ; set Z probe trigger value, offset and trigger height

    You're gonna want to measure your XY offset for the probe.
    https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe#Section_Measuring_Probe_X_Y_Offset



  • @Phaedrux Absolutely. Honestly, I was trying to get everything printing efficiently before learning how to actively use the probe! I had been having an issue with a solid mount that didn't move the probe when I changed out a nozzle too, but that has, luckily, been remedied as well. 🙂

    Thank you!


Log in to reply