Duet 2 Wi-Fi - Unable to connect over Wi-Fi or USB



  • Have had my Duet 2 Wi-Fi setup for a couple of months now. Today I switched the unit on and was unable to connect over Wi-Fi. Tried connecting over USB with no luck. Have removed Windows drivers, downloaded again from GitHub and installed. Am getting message in device manager: This device cannot start. (code 10). The specified request is not a valid operation for the target device.

    When I attach the USB I get the red 5V and USB light on, also the green 3.3V light and end stop lights. I've checked the reset button and it is not stuck in.

    ![Error message](c07179c5-e50e-4775-9b29-ebc6714f6b0c-image.png image url)

    I've gone through installing drivers on another laptop also running Windows 10 and have had the same results.

    Any help greatly appreciated.


  • Moderator

    What happens if you pull the SD card and power it up?

    Are any chips getting hot?

    https://duet3d.dozuki.com/Wiki/What_to_do_if_your_Duet_won't_respond



  • Hi Phaedrux, thank you for the response. Temps are around 28 degrees. The only hot spot I can find is around R31 which is around 37 - 40 degrees C. Although after a few minutes that comes down to 27-28 degrees. I'll have a look at the link tomorrow to see if there is anything else in there.
    Thanks again.
    Pete.



  • How confident/accurate would you say R31 is?
    537a2cf1-e61f-478d-a550-d83f96a59f6b-image.png

    R31's job is to monitor the usb voltage, and there shouldn't be any current or heat of significance there afaik

    (*esus, how can I make pictures smaller?? 4k screen and tiny screengrabs are shown as huge..)



  • Hi Bearer. It's when I have the usb cable connected that it is at the higher temperature. Although after about 4-5 minutes it does come down 27-28degrees C. I'm using an infrared thermometer with a target light, so even if it's not exactly accurate it is still showing a difference between components, but nothing too drastic... hopefully?
    Regards,
    Pete.



  • @Phaedrux Hi Phaedrux. I had a look at the URL and followed a few of the diagnostic methods, including resetting the board with the jumper. Unfortunately no change. I also held in the reset button and connected the USB. The diagnostics light did not come on as I was expecting based on the documentation. The device appears in the device manager as 'Unknown USB Device (Device Descriptor Request Failed)'. I've also uninstalled all USB devices, rebooted the laptop and tried again, same result. I also installed the drivers manually using 'add legacy hardware' option. An error code of 10 is listed against the drivers, but I think this is a red herring as the device is not being detected correctly, so I would expect to see this error. I think I've reached the point where I need to go back to the supplier.


  • Moderator

    Can you post some high quality photos of the top of the board? We might see a failed chip or something like that.

    When and where was it purchased?

    Is the fuse intact?



  • Hi Phaedrux

    I've uploaded two pictures, top and bottom of board. The best I can do I'm afraid. I've tested all 3 fuses on the board and they are okay. I bought the card from Oozenest, they are collecting the card on Monday 21st.
    IMG_20200919_152949.jpg
    IMG_20200919_152917.jpg


  • Moderator

    @PeteL said in Duet 2 Wi-Fi - Unable to connect over Wi-Fi or USB:

    they are collecting the card on Monday 21st.

    Ok, so you've initiated a warranty replacement?



  • Hi Phaedrux, yes, I have.
    Regards, Pete.


Log in to reply