Unable to use chamber heater unfinite



  • Hello. I would like to run the chamber heater infinite, is it possible? The chamber is to big for the heater to reach max temp. I run the heater with SSR and 230v. I get a error message after a few seconds with the heater on: Error: Heater 2 fault: temperature rising much more slowly than the expected 1.8°C/sec
    Why do i get this with bang-bang enabled? I though it was monitoring only with PID.

    ; Chamber heater
    M308 S2 P"e1temp" Y"thermistor" T100000 B3950 ; configure sensor 2 as thermistor on pin e1temp
    M950 H2 C"e1heat" T2 ; create chamber heater output on e1heat and map it to sensor 2
    M143 H2 S80 ; set temperature limit for heater 2 to 80C
    M307 H2 B1 ; enable bang-bang mode for the chamber heater
    M141 H2 ; map chamber to heater 2

    Please ask if more info is needed.

    2020-04-07 16.56.18 (Copy).jpg



  • Did You run PID tuning ?

    OK, Did noticed bang-bang mode. But I would set PID, and run autotune.


  • Moderator

    As BoA says you'll need to either PID auto tune the heater to give the firmware an idea of how it performs, or you'll have to derive your own PID values manually. Chamber heaters have a slow heat up time so you may need to increase the dead time.

    https://duet3d.dozuki.com/Wiki/Tuning_the_heater_temperature_control

    https://duet3d.dozuki.com/Wiki/Connecting_and_configuring_a_chamber_heater



  • Also, if the printer is fully enclosed, adding fan blowing through heater might help a little to dissipate heat from heater to chamber air. And heater itself will work on lower temps which would make it to live longer 🙂


Log in to reply