Low voltage on Duet 2 Maestro FAN1 and FAN2 ports



  • Hello everyone,

    I'm in the process of upgrading my Ender 3 Pro fans to 12V. I'm using Duet 2 Maestro with firmware 3.1.1 (2020-05-19b2).

    I have a buck converter with inputs wired to VIN+ and VIN-. The converter is set up to output 12V and this is verified with multimeter.

    I have wired the buck converter OUTPUT+ to both V_FAN_A (jumper middle pin) and V_FAN_B (jumper middle pin). (Same problem existed when I had it only wired to V_FAN_A)

    When I power up the machine and start checking the fan ports with multimeter I get the following results:

    Always-on-fan 12V (correctly).
    FAN0, FAN1 and FAN2 0V (correctly).

    After this I heat the hot end to 55 C (fan temperature threshold at 45 C), set the part cooling fan to 100% from DWC and check the ports with multimeter again:

    Always-on-fan 12V (correctly)
    FAN0 12V (correctly)
    FAN1 7V
    FAN2 7V

    So something is wrong with FAN1 and FAN2 voltage and I can't figure out what it is. Can anyone help?


  • Moderator

    Can you post your fan configuration section?



  • @Phaedrux Sure

    ; Fans
    M950 F0 C"fan0" Q500                               ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1                                     ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500                               ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S0 H1 T45                                  ; set fan 1 value. Thermostatic control is turned on
    M950 F2 C"fan2" Q500                               ; create fan 2 on pin fan2 and set its frequency
    M106 P2 S0 H1:0 T45                                ; set fan 2 value. Thermostatic control is turned on
    

  • administrators

    The reason is the S0 parameters in the M106 commands for your thermostatic fans. When a fan is configured in thermostatic mode, the S parameter is the maximum allowed PWM (to handle fans that are too powerful when run at full PWM). However, RRF forces a minimum PWM of 50% for thermostatic fans.

    So either remove the S parameters for those M106 commands, or change them to S1.



  • @dc42
    Thanks a lot! This fixed it.


Log in to reply