Soft-reset PanelDue



  • Note the following is specific to Duet 3 and that we are currently running 3.2b1.

    Is there a way to soft-reset the PanelDue? We've run into a scenario where this is required but have not found a way around it. Could power simply blink on io_0 to trigger this? We tried, but no luck so far..

    If this is not currently available, I would like to request this be reviewed as an enhancement.

    The details of why we need this is when removing vIn power from a Duet 3 / RPi and running in a low power mode. In this condition, the toolboard is not available. We have everything worked out, but since the PanelDue isn't refreshing like DWC, it is causing issues as tools that no longer exist still show on the display.



  • @oozeBot could you maybe disable out0 as a paneldue port and then reconnect it?
    Or run the power from a fan port with a buck converter to get 5v? So it's set to come on at power on but can have the power removed?
    Or use a small relay powered but an output port to do that job.


  • Moderator

    @jay_s_uk said in Soft-reset PanelDue:

    Or run the power from a fan port with a buck converter to get 5v?

    I think that's a clever way to do it.

    But it would maybe be useful to have a command that could be sent to reset the paneldue. It does have a reset button afterall.



  • The issue with using a buck converter is that I want the PanelDue to stay on when running in low power mode.. which works now with the dedicated 5v power supply. That way, I can run the power toggle macro from it to turn the machine back on.. but it's in this weird state that needs to be refreshed.


  • Moderator

    @oozeBot Which PanelDueFirmware version is this? I tested with v3.2.0 (release candidates) hot-plugging a PanelDue between various Duet mainboards (power was ensured by a USB connection) and it always correctly updated the internal data model.
    So if you are experiencing this issue with one of these release candidates please let me know such that I can fix this (of course I need more info then).

    Earlier firmware versions are expected to not handle these kind of hot-config-changes very well.



  • @wilriker I forget which firmware that I was running when it was reported, but it's always been the latest. I'll try this once again today after upgrading to your latest beta and report back if I still see it occuring with more info.

    Thanks


Log in to reply