Mesh compensation no longer working in RRF3



  • I use an inductive sensor wired to the e0stop and I used to be able to do mesh compensation and use the bed leveling assistant but now it's giving me the error G30: Z probe 0 not found. It looks like G29/30 can only use probe 0 which look like it should be setup by default from the wiki on M558. Is my "Z probe connected to E0 endstop input" not a z probe? Or how should I perform G29/G32 operations now?

    ; config.g
    ...
    
    ; Define Position of Bed Leveling Screws
    M671 X11:296:153 Y0:0:280
    
    ; Endstops
    M574 X1 S1 P"xstop"
    M574 Y1 S1 P"ystop"
    M574 Z1 S1 P"!e0stop"
    ;X & Y are active high
    ;Z is inverted, see M558 below
    
    ; Set Z probe type
    M558 P5 C"!e0stop" H3 F120 T18000
    
    
    G31 X5 Y-47 Z0.5	; Set Z probe trigger value, offset and trigger height. Higher value brings nozzle closer to bed
    			; (this G31 line must come *after* M558 line)
    ...
    
    ; bed.g
    ; called to perform automatic bed compensation via G32/29
    
    M913 Z70			; Reduce Z motor current so if the Z sensor fails 
    				; and there's a head crash there's less force
    
    M561				; Clear any existing bed transform
    G29 S2				; Clear previous height map
    G28 ; home
    
    G30 P0 X11  Y0   Z-99999 ; probe near an adjusting screw
    G30 P1 X296 Y0   Z-99999 ; probe near an adjusting screw
    G30 P2 X153 Y253 Z-99999 S3 ; probe near an adjusting screw and report adjustments needed
    
    M913 Z100			; Restore Z motor current currents
    


  • Your issue if you're trying to set the same pin as a z endstop and a z probe.

    Just remove the M574 for Z



  • @gamer_013 said in Mesh compensation no longer working in RRF3:

    M574 Z1 S1 P"!e0stop"

    replace with
    M574 Z1 S2 ; configure Z-probe endstop for low end on Z



  • @gamer_013

    Hi,

    JOOC why are you not using the Z-probe connector?

    Frederick



  • @jay_s_uk said in Mesh compensation no longer working in RRF3:

    Your issue if you're trying to set the same pin as a z endstop and a z probe.

    Just remove the M574 for Z

    Removing this line gives me a "failed to enable endstops" error when trying to home Z.

    @Veti said in Mesh compensation no longer working in RRF3:

    @gamer_013 said in Mesh compensation no longer working in RRF3:

    M574 Z1 S1 P"!e0stop"

    replace with
    M574 Z1 S2 ; configure Z-probe endstop for low end on Z

    That did it! I didn't think so try that as the gcode wiki said "The S2 option of M574 is intended for use only when axes other than Z are using the Z probe for homing." Which confused me because I was using my "z probe" to home the z axis so I didn't consider the S2 option. Thank you!

    @fcwilt said in Mesh compensation no longer working in RRF3:

    @gamer_013

    Hi,

    JOOC why are you not using the Z-probe connector?

    Frederick

    This is carried over from an old config that I used long ago and the example happened to have it setup that way. I may convert it over when I get some time to re-configure my printer.


Log in to reply