RRF 3.1.1: M408 S0 R1's response



  • Hi everyone,

    This is the response I get after sending a M408 S0 R1 command in 3.1.1:

    {"status":"I","heaters":[23.9,24.1,24.2],"active":[0.0,0.0,0.0],"standby":[0.0,0.0,0.0],"hstat":[0,0,0],"pos":[294.000,27.000,5.194],"machine":[294.000,27.000,5.494],"sfactor":100.0,"efactor":[100.0,100.0],"babystep":0.300,"tool":-1,"probe":"0","fanPercent":[0.0,100,100,0,0,-1,-1,-1,-1,-1,-1,-1,-1],"fanRPM":[-1,-1,-1,-1],"homed":[1,1,1],"msgBox.mode":-1}<LF><LF>ok<LF>

    In RRF 3.0 there is still an information about our Wifi module ("resp":....), but now it's completely gone. This has an impact on my display software. I can not see the IP address anymore on the display.

    I've also tried with a M408 S0 command without R1, but I got the identic response as before (with R1).

    Maybe someone can help me. Thankyou!



  • M408 is slowly being replaced with M409 as the object model becomes the drivers.



  • @jay_s_uk Thank you for your response, but I could not see any information about the Wifi module after sending a M409 command.

    {"key":"","flags":"","result":{"boards":[{}],"directories":{},"fans":[{},{},{},{}],"heat":{},"inputs":[{},{},{},{},{},{},{},null,null,{},null,{}],"job":{},"limits":{},"move":{},"network":{},"scanner":{},"sensors":{},"seqs":{},"spindles":[{},{},{},{}],"state":{},"tools":[{},{}],"volumes":[{},{}]}}<LF>ok<LF>



  • @illy M409 by itself only shows the top level of the object model. It's possible to drill down further into the JSON output. Please see here for more info. https://duet3d.dozuki.com/Wiki/Object_Model_of_RepRapFirmware and here https://duet3d.dozuki.com/Wiki/Gcode#Section_M409_Query_object_model



  • @jay_s_uk thank you for the information!


Log in to reply