Using e1 to control heatbed, (with mosfet)



  • Hi,

    I'm mainly asking for two reasons.
    Current setup I'm running a 480 watt heatbed, 24volt. Using a mks 30a mosfet.

    Everything "works", heats up, keeps temps within a 1-2 c during prints. But the reason I'm considering using e1 to control the mosfet is.

    First question. Whenever the board is running (motors, hotend and heatbed) and pwm is controlling the mosfet. it makes noise. electrical noise that I can see matches the leds intensity from the duet 2 wifi board. and it's not coming from the mosfet. Can't really explain. I could try to record it. As the mosfet is handling the roughly 20 amps, I figure I could try to use the e1 instead of the heatbed and shouldn't really be that much power needed from the e1 connection.

    Is there any reason I couldn't/shouldn't do this, or even use a heater connector from the expansion.

    Second question. which should properly have been the first one. Is there a reason why the board would make this noise?

    Note: I'm running a 24v 33amp psu.
    Board: Duet 2 WiFi (2WiFi) V.1.03
    Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 3.1.1 (2020-05-19b2)
    Duet WiFi Server Version: 1.23

    Edit: Link to video Can be hard to hear, not easy to record it.

    Br
    Alan



  • Do You have a magnetic heatbed?

    First question - with mosfet You can use basically any output.

    Second question - it is not the board. More likely cables or heatbed itself.



  • Hi,

    It's just a regular mk2a 300x300 with a pei sheet.



  • @iZippy82 Assuming you are using heater 0 as the bed heater, what frequency value (the Q parameter) have you set in the M950 command for H0? It is generally recommended to set it to 10Hz when using SSRs and the like but you could try other values for your Mosfet. Also have you run heater tuning and are you using PID or bang-bang mode?



  • @deckingman

    My m950
    M950 H0 C"bedheat" T0
    it's set to PID and I've run auto m303 h0 s60 and saved it with m500.

    The config.overide has values stored in it.

    I've not set the frequency. I'm guessing that's running at default value, i'll try to see if I can find the recommended freq for the mks mosfet is.

    Thanks I'll try it.



  • @iZippy82 said in Using e1 to control heatbed, (with mosfet):

    Everything "works", heats up, keeps temps within a 1-2 c during prints. But the reason I'm considering using e1 to control the mosfet is.

    you never told us your reason



  • @iZippy82 I might be wrong but I think that in Duet 2, the default frequency for the bed heater was 10Hz but in Duet 3 it might be different. So try adding Q10 to your M950.



  • @Veti

    the reason is in the first post. (I agree it's not the best writing, I'm blaming that on lack of coffee.)
    "it makes noise. electrical noise that I can see matches the leds intensity from the duet 2 wifi board."
    "Is there a reason why the board would make this noise?"

    There is short video linked as well.



  • @iZippy82 said in Using e1 to control heatbed, (with mosfet):

    As the mosfet is handling the roughly 20 amps

    The Duet 2 (WiFi and Ethernet) supports power distribution to and control of three heaters: a heated bed (assumed to be the highest current draw with a maximum of 18A

    20 A is too much for the duet.



  • @Veti

    Which is why it's running on the mks mosfet, that can handle 30 amps ☺



  • @deckingman

    I've just tested with Q10.

    The noise is almost gone and the LED is now "flashing" now.

    Thanks



  • @iZippy82 said in Using e1 to control heatbed, (with mosfet):

    @deckingman

    I've just tested with Q10.

    The noise is almost gone and the LED is now "flashing" now.

    Thanks

    Sounds like it's fixed then - you could try playing around with the frequency to see if you can get it even quieter.



  • @deckingman

    Yeah, I sure will.

    thank you again, the "noise" was driving me mad. 😵


Log in to reply