Z-Probe and Z-Endstop at the same time



  • Is it possible to use Z-Probe device in order to detect Z-MIN of the printer, and a Z-Endstop to detect Z-MAX?

    I've read it is not possible to have two endstops (min and max) in the same axis, but I am not sure if the Z-Probe is an exception to this rule.

    I am building an Hypercube (CoreXY) design and would like to avoid the bed movement to crash on the bottom side if it lowers too much.

    Just limiting the dimensions on the Z-axis does not seem to work before the printer has done initial Z-homing.

    thank you!!



  • @daparix

    https://duet3d.dozuki.com/Wiki/Connecting_an_Emergency_Stop

    you could make the endstop at the bottom an emergency stop.


  • Moderator

    Since everything is configured with gcode in real time you can have the zmin endstop act as an estop to prevent going too far down, and then reconfigure it as an actual endstop before homing to zmin. The probe is separate entirely.

    I use an optical endstop on zmin and the combination of axis limits and allowing for a few mm of physical travel to drop beyond that limit I have never had an issue with the bed bottoming out or needing an estop there.

    would like to avoid the bed movement to crash on the bottom side if it lowers too much.

    I guess the question is when do you expect that to happen?



  • @Phaedrux I have done some macros to allow moving the bed up and down even without having homed it first.

    Maybe it is relevant to say my Z-Probe is piezoelectric, so configuring the sensitivity of the PCB needed to be done in addition to the printer tuning itself.

    I used in order to do initial tests while configuring the Z-probe (so I needed to retract the bed to retry before I did an actual homing). I did a crash once (I had my bed too low and then tried to do a Home-X, so the bed went down a bit more), and would like to not repeat the experience anymore!

    I am not expecting this to happen during normal printing, but I can tell because my own experience that it can happen while the printer is being tuned/configured (by a novice like me)!!



  • @daparix To expand on what @Veti and @Phaedrux have said, if you home to Z min then set the the Z axis travel limit in M208, the firmware will not permit any move to exceed that Z max position. The only way that you can command a move to exceed the allowable Z max is to make that command before the axis has been homed and to do that, you have to either include an S or H parameter (depending on firmware version) to the G1 move, or issue an M564 command before sending a G1 Zn command. So it's pretty difficult to exceed the axis maximum travel but if you want the belt and braces approach, you can use an additional switch as described.

    Edit. I was typing that before I saw your last post so if you are worried, go for the additional switch. Another tip, always lower the Z motor current when homing or "playing around" - it will help to prevent and damage in the event of a mishap.



  • Thank you everybody for the helpful options!

    I think simplest for my case is the emergency button one, although the explanation that the gcode configuration is actually "real time" opens other ideas (for other requirements) that I need to explore deeper as I gain confidence.

    Lowering the Z motor current when I am playing with the configuration is also something that I will follow from now on.

    Thank you again!


Log in to reply