Win 7 laptop connection issues



  • I have beat my head enough, so I'll surrender and ask.

    With my DuetWifi, I can connect to it with my WIN 7 PC, phone, Samsung tablet, but not either of my Win 7 laptops. I can ping the Duet from both laptops, but entering the IP address in the address bar results in a long wait for nothing to happen.

    "Honey, can you type 192.168.1.3 into your address bar?" Win 10 laptop…boom. Works on hers.


  • administrators

    Which browser are you using on those laptops? You should use either Firefox or Chrome with Duet Web Control.



  • IE11 on both laptops as well as Win 7 PC.

    I'll give it a shot.



  • Firefox didn't help.


  • administrators

    IE is a definite no-no as far as DWC is concerned. Edge works only partially.


  • administrators

    I find the least issues with Chrome, if Firefox is not working are you blocking the JS within security settings?



  • I took one laptop and completely disabled everything. Reset all internet settings. Deleted cookies, history, cache. Nothing helped.

    Even compared settings from my PC/Desktop that does work. (other than the Java error I am getting and have another post about).


  • administrators

    Did you try Chrome?



  • Just tried it. Doesn't work either.


  • administrators

    As you have said this is very odd, I assume the laptops that don't connect are on the same network? Do you get any hints when you inspect the traffic seen by chrome when trying to connect?



  • All computers/tablets/phone on the same network. Sorry, but I have already uninstalled Chrome and Firefox since they didn't work. Give me something to test in IE and I'll be all over it.


  • administrators

    Ahh sorry well IE does not work properly the last time I tested it as it does not implement the HTML 5 standard fully. You will need to use firefox or chrome. As far as the issue is concerned I am trying to see if the browser is connecting to the duet and then failing to load something or if its not connecting at all. Chrome (and maybe firefox &IE) allow you to get more information about what the browser is doing by inspecting the web page.



  • I see. I'll redownload Chrome. Let me know what I need to do.



  • Loaded Ubuntu on an SD card, booted up to it and I can access DWC without an issue using Firefox.



  • you might try adding the url to trusted sites in browser options. depending on your AV/malware/ browser settings, security could be blocking you in win7 and of course make sure you have applied the latest patches from Microsoft at a minimum you should have updates from May. April was when the wannacry virus broke and they released a bunch of security updates based on it…



  • Fully up to date. Tried adding it to safe sites. Even tried a new router since it was so old that you couldn't set the date past 2015. But, sadly, nothing has been able to fix the issue. Tried a third Win 7 laptop that I own….nothing.



  • you can ping by ip address, how about a tracert to see what is in between your pc and printer? any firewalls ect? i use chrome BTW.

    open command prompt
    type tracert "printer adx"

    from your description, only thing in between is your switch\router right?

    win 7 32 bit or 64?

    depending on router model, log in and it should tell you IP and net name of printer. try netname as well and see if it yields different results. I know if i leave my printer off for a couple days or so, the IP address often changes so net name is a great workaround for DHCP



  • I have the printer locked into an IP. I can ping it using the IP address. Same MSE on all computers and I have tried disabling via msconfig to try without and it didn't help.

    ping duetwifi = ping request could not find–- Even on the PC that can connect, so maybe I am doing something wrong here.

    Tracert (IP Address) shows 1: * 2837ms 10ms

    All laptops and one PC (that can connect) are going through one wifi router.

    64 bit.

    Netname? Couldn't find any relevant info on how to use.



  • I am finally able to connect to the DuetWifi with my laptop after editing the registry and removing all instances of Java. I then downloaded the latest Java and installed it.

    I still get this error when trying to view the System Editor.

    [[language]]
     JavaScript Error
    
     A JavaScript error has occurred so the web interface has closed the connection to your board. It is recommended to reload the web interface now. If this happens again, please contact the author and share this error message:
    
    Message: Object doesn't support property or method 'endsWith'
    URL: http://192.168.1.7/js/dwc.js
    Line: 3333:2
    Error object: {"description":"Object doesn't support property or method 'endsWith'","number":-2146827850,"stack":"TypeError: Object doesn't support property or method 'endsWith'\n at addSysFile (http://192.168.1.7/js/dwc.js:3333:2)\n at success (http://192.168.1.7/js/dwc.js:3395:8)\n at i (http://192.168.1.7/js/dwc.js:2:27598)\n at j.fireWith (http://192.168.1.7/js/dwc.js:2:28311)\n at A (http://192.168.1.7/js/dwc.js:4:13856)\n at Anonymous function (http://192.168.1.7/js/dwc.js:4:16146)"}
    
    

  • administrators

    That could mean that you are using incompatible versions of Duet Web Control and RepRapFirmware. Which versions are you using?

    Please confirm that the browser is Chrome or Firefox.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.