Problem to config fan



  • hey guys.

    i try to config my fans for the duet 3.

    my problem is with the actual config, if i turn on fan on duet web the hotend and the partfan starts with the same command.... if i heat up my hotend the hotend fan starts at Temp 45. thats ok. if i start printing the partcoolingfan starts full speed at second layer. in the slicer i told him to start with 20% not full speed. anyone an idea whats wrong in my config? don´t know if Q25000 is correct. found it in an other config.

    ; Heaters
    M308 S0 P"temp1" Y"thermistor" A"Heizbett" T100000 B4138 ; configure sensor 0 as thermistor on pin temp0
    M950 H0 C"out1" T0 ; create bed heater output on out0 and map it to sensor 0
    M143 H0 S110 ; set temperature limit for heater 0 to 120C
    M307 H0 A255.6 C558.3 D1.8 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit and PID settings
    M140 H0 ; map heated bed to heater 0

    M308 S1 P"temp0" Y"thermistor" A"Nozzle" T100000 B4725 C7.06e-8 ; configure sensor 1 as thermistor on pin temp1
    M950 H1 C"out0" T1 ; create nozzle heater output on out0 and map it to sensor 1
    M143 H1 S245 ; set temperature limit for heater 1 to 245C
    ;M307 H1 A384.5 C364.6 D3.3 B0 S1.00 ; disable bang-bang mode for the nozzle heater and set PWM limit and PID settings
    M307 H1 A434.1 C185.4 D7.0 S1.0 V24.0 B0

    ; Fan Hotend
    M950 F1 C"out7" Q16000 ; create fan 1 on pin out7 and set its frequency
    M106 P1 S1 H1 T45 ; set fan 1 value. Thermostatic control is turned on

    ; Fan Partcooling
    M950 F0 C"out8" Q25000 ; create fan 0 on pin out8 and set its frequency
    M106 P0 S0 H-1 ; set fan 0 name and value. Thermostatic control is turned off

    The hotendfan is an Noctua NF-A4x10 FLX
    the partcoolingfans is an Sunon Radial fan 50x50x15mm MF50151VX-A99 DC 12V 6000 U/min


  • Moderator

    Post your full config.g with the tool section.

    You are using a very high PWM frequency for the part cooling fan with Q25000 which may be reducing the available speed range for the fan. So even though you're requesting 20% it's still spinning almost as fast as it can. Try the default Q500.



  • @Phaedrux

    Hi, thx for your answer. It‘s the same if i try it with Q500..... when I start print, fan runs on full speed... also in duet web I only can turn on or off


  • Moderator

    @Phaedrux said in Problem to config fan:

    Post your full config.g with the tool section.


  • Moderator

    @ErwinH78 said in Problem to config fan:

    The hotendfan is an Noctua NF-A4x10 FLX
    the partcoolingfans is an Sunon Radial fan 50x50x15mm MF50151VX-A99 DC 12V 6000 U/min

    I've got the same fans and I'm using Q100 on the sunon and Q1000 on the noctua.


Log in to reply