BLTouch not responding properly Duet 2 Wifi



  • Hi everyone!

    I recently got myself a Delta TeVo Little Monster printer, and it came with a Duet 2 Wifi board (FIRMWARE_VERSION: 3.0 ELECTRONICS: Duet WiFi 1.02 or later)

    I've setup everything, and everything seems to be working except for the BLTouch. When I try to probe it using M401 it does probe, but nothing happens when I do M402.
    G29 makes the printer start doing a manual mesh bed level (before I updated www files it opened a dialog where I was able to adjust the z height at the point, now it's just a blank dialog with an "OK" button that makes it go to the next point).

    I've tried to read the entire Wiki on adding a BLTouch, and also the BLTouch troubleshooting, with no luck.

    The wiring is as in the Wiki here.

    I suspect it's got something to do with configuration since I'm not the best at that ­čśü I tried using the code on the Wiki, but the only thing that makes me able to do M401 is from the reprap configurator.

    config.g:

    ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Sat Oct 03 2020 21:40:02 GMT+0200 (Centraleurop├Žisk sommertid)
    
    ; General preferences
    G90                                                ; send absolute coordinates...
    M83                                                ; ...but relative extruder moves
    M550 P"TeVo Little Monster"                        ; set printer name
    M665 R155 L397.19 B155 H520                        ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0                                      ; put your endstop adjustments here, or let auto calibration find them
    
    ; Network
    M552 S1                                            ; enable network
    M586 P0 S1                                         ; enable HTTP
    M586 P1 S1                                         ; enable FTP
    M586 P2 S1                                         ; enable Telnet
    
    ; Drives
    M569 P0 S1                                         ; physical drive 0 goes forwards
    M569 P1 S1                                         ; physical drive 1 goes forwards
    M569 P2 S1                                         ; physical drive 2 goes forwards
    M569 P3 S1                                         ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3                                   ; set drive mapping
    M350 X16 Y16 Z16 E16 I1                            ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z80.00 E403.00                   ; set steps per mm
    M566 X1200.00 Y1200.00 Z1200.00 E1200.00           ; set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z18000.00 E1200.00        ; set maximum speeds (mm/min)
    M201 X1000.00 Y1000.00 Z1000.00 E1000.00           ; set accelerations (mm/s^2)
    M906 X1200 Y1200 Z1200 E1200 I30                   ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                            ; Set idle timeout
    
    ; Axis Limits
    M208 Z0 S1                                         ; set minimum Z
    
    ; Endstops
    M574 X2 Y2 Z2 S1				; set active high endstop
    
    ; Z-Probe
    ;M307 H3 A-1 C-1 D-1 ;
    
    ;M558 P9 H5 F100 T2000 ;
    
    ;G31 X0 Y0 Z0 P25 ;
    ;M557 R155 S45 ;
    
    M307 H3 A-1 C-1 D-1	
    M950 S0 C"exp.heater3"                             ; create servo pin 0 for BLTouch
    M558 P9 C"^zprobe.in" H5 F120 T6000                ; set Z probe type to bltouch and the dive height + speeds
    G31 P500 X0 Y0 Z0                                  ; set Z probe trigger value, offset and trigger height
    M557 R155 S45                                      ; define mesh grid
    
    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138     ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0                              ; create bed heater output on bedheat and map it to sensor 0
    M307 H0 B1 S1.00                                   ; enable bang-bang mode for the bed heater and set PWM limit
    M140 H0                                            ; map heated bed to heater 0
    M143 H0 S120                                       ; set temperature limit for heater 0 to 120C
    M308 S1 P"e0temp" Y"thermistor" T100000 B4138      ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1                               ; create nozzle heater output on e0heat and map it to sensor 1
    M307 H1 B0 S1.00                                   ; disable bang-bang mode for heater  and set PWM limit
    
    ; Fans
    M950 F0 C"fan0" Q500                               ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1                                     ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500                               ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H1 T45                                  ; set fan 1 value. Thermostatic control is turned on
    
    ; Tools
    M563 P0 D0 H1 F0                                   ; define tool 0
    G10 P0 X0 Y0 Z0                                    ; set tool 0 axis offsets
    G10 P0 R0 S0                                       ; set initial tool 0 active and standby temperatures to 0C
    
    ; Custom settings
    M519 D0 C3 P2 E6.0
    
    ; Miscellaneous
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss
    

    deployprobe.g:

    M280 P3 S10 I1; deploy BLTouch
    

    retractprobe.g:

    M280 P3 S10 I1; retract BLTouch
    
    


  • the retract and deploy have changed in V3

    M280 P0 S90 ; retract BLTouch

    M280 P0 S10 ; deploy BLTouch



  • Well that's progress! Now it's working (kind off). It probes but returns;

    4.10.2020 15.50.40	Error: Z probe was not triggered during probing move
    4.10.2020 15.50.46	Error: Compensation or calibration cancelled due to probing errors
    4.10.2020 15.50.34	Error: Z probe was not triggered during probing move
    4.10.2020 15.50.28	Error: Z probe was not triggered during probing move
    4.10.2020 15.50.22	Error: Z probe was not triggered during probing move
    4.10.2020 15.50.16	Error: Z probe was not triggered during probing move
    4.10.2020 15.50.10	Error: Z probe was not triggered during probing move
    4.10.2020 15.50.04	Error: Z probe was not triggered during probing move
    4.10.2020 15.49.57	Error: Z probe was not triggered during probing move
    4.10.2020 15.49.51	Error: Z probe was not triggered during probing move
    4.10.2020 15.49.44	Error: Z probe was not triggered during probing move
    4.10.2020 15.49.38	Error: Z probe was not triggered during probing move
    


  • check the wire going to zprobe.in



  • The wires seem fine... Could it have something to do with the BLTouch 3.3v logic bridge (as shown here)
    In the video he says to test it with a multimeter? Here I'm guessing you test the continuity? And it's suppose so show 0? On my multimeter it doesn't shows that there is continuity, and I'm sure the bridge is gone...



  • if you have the version 1.04 you do not need to cut the line anymore

    what version bltouch is it?

    with the bltouch you will not see 1000 because it just triggers it for a split second.



  • @Veti

    m115
    FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 3.0 ELECTRONICS: Duet WiFi 1.02 or later FIRMWARE_DATE: 2020-01-03b3
    

    I believe the BLTouch is SMART v.1.0

    The previous owner sold it with the BLTouch now working. He said it was a firmware issue on the original board.

    I got a spare BLTouch with the deal, and both are returning the same error.



  • @TokeDK said in BLTouch not responding properly Duet 2 Wifi:

    FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 3.0

    please update to 3.1.1 and try again



  • Now my endstops are not working... I tried to rebuild the config from the configurator with no succes.

    First I got the error "failed to enable endstops", then I changed my config to:

    ; Endstops
    M574 X2 S1 P"xstop"                                ; configure active-high endstop for high end on X via pin xstop
    M574 Y2 S1 P"ystop"                                ; configure active-high endstop for high end on Y via pin ystop
    M574 Z2 S2                                         ; configure Z-probe endstop for high end on Z
    

    Now when it's homing the endstops doesn't work, so the stepper motors keep going...



  • @TokeDK said in BLTouch not responding properly Duet 2 Wifi:

    TeVo Little Monster

    thats a delta. you have 3 endstops for each tower

    try

    M574 X2 S1 P"xstop" ; configure active-high endstop for high end on X via pin xstop
    M574 Y2 S1 P"ystop" ; configure active-high endstop for high end on Y via pin ystop
    M574 Z2 S1 P"zstop" ; configure active-high endstop for high end on Z via pin zstop



  • @Veti said in BLTouch not responding properly Duet 2 Wifi:

    M574 X2 S1 P"xstop" ; configure active-high endstop for high end on X via pin xstop
    M574 Y2 S1 P"ystop" ; configure active-high endstop for high end on Y via pin ystop
    M574 Z2 S1 P"zstop" ; configure active-high endstop for high end on Z via pin zstop

    Perfect! Now endstops are working. Although Z probe is still giving the same error:­čśľ

    	Error: Z probe was not triggered during probing move
    


  • post a picture of your wiring



  • 1

    2

    3



  • you really should recrimp your cables.

    can you try without extension cables? like this

    https://d17kynu4zpq5hy.cloudfront.net/igi/duet3d/KUDxTZSs3rnd3JVH.standard



  • Awesome, I set it up like you suggested and it works! So it is faulty wiring/connections. I will report back with my findings.



  • @TokeDK
    i suggest you get a crimping tool (i use engineer pa09). that way you can crimp the cables with the connectors supplied with the duet. (if you got them)



  • Hi,

    I suggest you get the proper connector parts for the Duet board and redo the wiring as needed.

    This is the tool I use for crimping the them:

    Crimping tool


Log in to reply