Proxy server?



  • I've searched for a definitive answer to this question but I haven't had any luck…

    Am I correct in understanding that the Duet Wifi can't be accessed outside of its local network by forwarding a port to it, and the only alternative is to use a proxy server such a Raspberry Pi?

    I found a short discussion on it and one of the participants stated that he easily set his up by forwarding port 80 to the duet's static ip, but I've had no such luck doing the same.
    After further searching I found other folks stating they resolved the issue by installing an RPi as a proxy server.

    Has anyone had success connecting to it by just forwarding a port?

    I just wanted to clarify before I ordered an RPi for nothing.

    Thanks in advance.


  • administrators

    I'll ask chrishamm to take a look at this, because I can't see any reason why port forwarding should not be possible with the Duet WiFi and he is currently doing some fixes to the WiFi firmware for the next 1.19 beta firmware.



  • I use the Duet via a static IP and port forwarding without any issues..


  • administrators

    The Duet WiFi with firmware 1.18.2 and earlier don't allow a static IP or gateway address to be configured, but 1.19 firmware does. So it may be that port forwarding already works if you use 1.19 firmware.



  • I have used Port forwarding on my Duet WiFi without fixing the IP Address by locking it to the same IP in the router and then port forwarding to it it worked for me at the time.



  • Thanks so much.
    I'm no I.T. expert by any means but I had wondered if the current firmware's lack of ability to configure a static ip was a factor.

    Do you think the current beta is worth a try or should I wait for the next release?

    Doug, this is exactly how I have mine configured but I haven't had any luck.



  • UPDATE:

    I figured out why I couldn't connect to the Duet remotely.
    I did not have Telnet enabled in my settings on the router.

    I remember enabling it when I first set things up, but before trying to connect to the duet, my router notified me that I had a firmware update while I was logged into the portal. I guess when the new firmware installed it set those particular admin settings back to default, and I didn't think to check it.

    I am in business!

    Thanks to all who responded.



  • Disregard that….

    I got all excited for nothing. I wasn't paying attention and I had my wifi enabled on my tablet when I tried to connect, so I was still in sidemy local network. I disconnected from the wifi and used the cell data and no joy.

    Back to the drawing board.



  • Try setting the port forwarding to be the DMZ in the router and don't forget to specify the correct port which I believe is the std 80

    Doug



  • Yeah, IP forwarding should work fine. However, exposing it without proper authentication means anyone can control your printer, so it's probably not a great idea. That's why I use a reverse proxy that adds HTTP authentication.



  • Doug,
    Thanks for the suggestion. I tried applying the DMZ to the forwarded port but still no luck.

    FWIW, I went ahead and bought a Raspberry Pi and installed Octoprint on it. It only took me about 5 minutes to get it connected outside of my network. I only mention this because if others have had luck connecting the Duet, then maybe it was my Router. But being able to connect the Raspi leads me to believe that it is a setting in my Duet's configuration.

    BTW, I am impressed with Octoprint, but I still prefer DWC over it any day even though I wish it had a couple of features that Octoprint has. If can I get the Duet to connect, I will use the Raspi on a separate ip to connect a streaming camera.

    I am going to try the Beta firmware that David mentioned. Maybe being able to assign a static ip on that end will fix the problem.
    I have just never been a fan of being a beta tester so I have held off on trying it. 😉



  • Installed v1.19 firmware.

    It works now but….

    I have to have wifi enabled on my phone to connect to the DWC. Once it's connected I can turn wifi off and control everything over the data connection. I can disconnect and reconnect, everything. But If I close the browser and then navigate to the IP just using the data connection, it hangs and won't connect.

    This is so strange as I can connect to the raspberry pi/octoprint server straight away with no issues.

    I'm baffled.



  • i'm having the same issue here and i need to solve it too!!!

    best regards



  • All this really depends on your router and has little to do with the Duet…. Depending on your router Asus or any router running firmwares like OpenWRT should support two different functions

    1. You should be able to configure a static IP address via the DHCP configuration page, using the DuetWifi's MAC address or any other IP connected device for that matter

    2. Port forwarding, once you setup the assigned IP address then you need to configure port forwarding to forward port 80 from your internet IP to your DuetWifi IP that you configured in the last step.

    3. Asus routers and others support reverse DNS services, even if your router does not support it, there are services that can be signed up for that do which gives you an easy way to connect to your home IP address via a url like: http://mynetwork.asus.com



  • Tape,

    I was able to connect to DWC once I upgraded to 1.19. SO that was fixed.
    But I never figured out why my phone wouldn't connect straight away.
    I don't think it's a DWC problem but maybe a security thing over my network.
    When I try to connect over data, I think my firewall doesn't recognize that connection as a secure one.
    I can connect via wifi anywhere that I can connect to wifi and it loads fine.
    I just connect, and get it working and leave that tab open in my phone's browser because once I am connected, it will stay connected with data only until I close the browser, or I have to power down the Duet for any reason.

    Btw, it's worth mentioning that I power my printer with an ATX PSU and I employ the option the Duet offers to power down to a low power state instead of completely off. So Even though my printer is off, I can still connect to DWC.

    I hope this helps.



  • i have the latest firmware as You can see
    M122
    === Diagnostics ===
    Used output buffers: 3 of 32 (9 max)
    === Platform ===
    RepRapFirmware for Duet WiFi version 1.19beta10+2 running on Duet WiFi 1.0
    Board ID: 08DDM-9FAM2-LW4S8-6JTDD-3S46J-93ZHW
    Static ram used: 20912
    Dynamic ram used: 94544
    Recycled dynamic ram: 3328
    Stack ram used: 1304 current, 4824 maximum
    Never used ram: 7464
    Last reset 00:08:30 ago, cause: power up
    Last software reset reason: User, spinning module GCodes, available RAM 3240 bytes (slot 0)
    Software reset code 0x0003, HFSR 0x00000000, CFSR 0x00000000, ICSR 0x00400000, BFAR 0xe000ed38, SP 0xffffffff
    Error status: 0
    Free file entries: 9
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms
    MCU temperature: min -250.7, current 35.6, max 36.2
    Supply voltage: min 12.0, current 12.0, max 12.2, under voltage events: 0, over voltage events: 0
    Driver 0: stalled standstill
    Driver 1: stalled standstill
    Driver 2: stalled standstill
    Driver 3: standstill
    Driver 4: standstill
    Date/time: 2017-07-20 18:21:02
    Slowest main loop (seconds): 0.007690; fastest: 0.000030
    === Move ===
    MaxReps: 2, StepErrors: 0, FreeDm: 240, MinFreeDm 236, MaxWait: 3682ms, Underruns: 0, 0
    Scheduled moves: 8, completed moves: 8
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    Probe change coordinates:
    === Heat ===
    Bed heater = 0, chamber heater = -1
    Heater 1 is on, I-accum = 0.0
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    Network state is running
    WiFi module is connected to access point
    WiFi firmware version 1.19beta9
    WiFi MAC address 5c:cf:7f:ef:3f:a8
    WiFi Vcc 3.07, reset reason Turned on by main processor
    WiFi flash size 4194304, free heap 32464
    WiFi IP address 192.168.1.90
    WiFi signal strength -35dBm
    HTTP sessions: 1 of 8
    Socket states: 2 2 0 0 0 0 0 0
    Responder states: HTTP(1) HTTP(2) HTTP(0) HTTP(0) FTP(0) Telnet(0)

    i have the port 80 open and forward to the ip 192.168.1.90 but i cant connect from the outside, only inside the network.
    but if i connect inside the network via wifi and then disconnect wifi (still connected by 4G), i'm still able to control the duet.
    i have an arduino Yun and i can control it from the outside with no problems at all!!!

    best regards



  • Then you're describing the same situation that I mentioned above.

    I just connect when I'm around wifi, and leave that tab open. If I want to search for something I just open another tab and leave the Duet tab in the background. Or I just find a PC that I can connect from, which in my case is usually my work PC.



  • Yes exactly the same.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.