Intermittent stepper driver issues



  • I have a Maestro running 24.2v with a new meanwell LRS350 24v power supply, configuring the new board for a new system, copied across the sdcard from an identical build and proceeded to start testing the system, first off had issues with no E0 drive, then could not home the system axis on XYZ, so tried the Test Motors macro, found E0 not turning and on 2nd part of test both Z axis motors stalled and started emitting high vibrational sounds like high pitched squeal and motor spindles locked solid, when the test then reversed the motor direction the spindles unlock and then immediately locked again and this continues until either i cancel the test using shut down button (STOP) or power off the board and supply ?.

    Went through all the setting in the config.g files, checked the sdcard for errors, upgraded to 3.11 and reconfigured new config.g, exactly the same errors so went back to original Maestro firmware and started all over again, no difference.

    Swapped board out with new spare stock, using the same SDcard and Configuration no issues with the stepper motors all functioning as should be.

    Have ran diagnostics on the power supply, no over-voltages detected and steady output of 24.12V on all rails, tested the stepper motors on an alternate system all running normally.

    At a loss as to what can cause this, first failure on this board for me, Have requested RMA.

    Regards

    Shaun


  • Moderator

    When and where did you purchase the board?

    Please share the config.g used. Also provide the results of M122 and M98 P"config.g"



  • The board was purchased in the UK direct from Duet3d on the 15/07/2020.

    The config.g is irrelevant as the config.g was used on the spare stock board and that worked 100% correct, the issue is with the stepper drivers circuitry or some part of the mainboard has some components that are failing when the system powers up.
    The power supply has been tested and found without fault and the stepper motors independently tested on alternate build system also without fault, all units are brand new, when I build printers or upgrades all component's are tested before a complete assembly where as I can be confident that the components dont have faults.

    The components did not fail under the config.g they failed under the test motors macro provided in the firmware accessed from the dashboard that is automatically loaded into the build.

    The test programs are always used when first test is required, this is the first board that has failed a self motors test.

    Here is the test macro for the motor test.

    ; Motor Test Routine for Duet 2 Maestro August 2018

    ;Start logging
    M929 P"test1log.txt" S1

    ; Test motors
    ;----setup motors for test----

    ;The printer dimensions are deliberately set very high to allow a lot of moves during testing
    M584 X0 Y1 Z2 U3 V4 ;Set all motors up as Axis
    M906 X1400 Y1400 Z1400 U1400 V1400 I100 ; Set all motors to 2A with no idle current reduction
    M201 X10000 Y10000 Z10000 U10000 V10000 ; Acceleration limits (mm/s^2)
    M203 X100000 Y100000 Z100000 U10000 V10000 ; Maximum speeds (mm/min)

    G92 X0 Y0 Z0 U0 V0 ;Set them all to 0

    ; Test motors

    M291 P"The motors will start to move. Press all 5 endstops, 1 at a time to confirm the motors stop moving" R"Homing Test" S2
    G91 ; use relative positioning
    G1 S1 X3200 Y3200 Z3200 U3200 V3200 F1000 ; move XYZUV motors, stopping when endstops are triggered
    ;----end homing lines----

    M291 P"The motors will start to move backwards and forwards together. Check that they all move in both directions" R"Direction Test" S2
    G91
    G92 X0 Y0 Z0
    G1 S2 X400 Y400 Z400 U400 V400 F9000
    G1 S2 X-400 Y-400 Z-400 U-400 V-400 F9000
    G1 S2 X400 Y400 Z400 U400 V400 F9000
    G1 S2 X-400 Y-400 Z-400 U-400 V-400 F9000
    G1 S2 X400 Y400 Z400 U400 V400 F9000
    G1 S2 X-400 Y-400 Z-400 U-400 V-400 F9000

    M18 ; disable motors
    G92 X0 Y0 Z0 U0 V0 ;Set them all to 0
    M291 P"End Of motor Test" R"Motor Test" S2

    M122 Gave no error warnings or messages, all drives were OK all voltages were 24.2v

    M98 P Config.g
    HTTP is enabled on port 80
    FTP is disabled
    TELNET is disabled

    The test motor test actually passes and gives no errors when the motors jam, so that does not make sense when i would have expected to see an error in the text logs but none ?, this is the first board out of 12 Maestro boards that has shown a failure under the test macros.


  • Moderator

    Please find the warranty return form on this page to initiate a warranty claim. Include a link to this thread as authorization.

    https://www.duet3d.com/warranty



  • @Phaedrux Completed yesterday, but forgot to include link, so edited the form just now and resubmitted with link.
    Thanks for your help, sorry if I came over a wee bit arrogant over the M221 etc but really did not need this issue at the mo under the present pandemic as been hit really hard to keep sales going.


Log in to reply